Bug 661766 - [abrt] Crash while using mouse-wheel on "From:" combobox in compose window / compose_show_first_last_header at compose.c:10787
Summary: [abrt] Crash while using mouse-wheel on "From:" combobox in compose window / ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: claws-mail
Version: 13
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL: http://www.thewildbeast.co.uk/claws-m...
Whiteboard: abrt_hash:1b12afd5001f940bb307efb47f4...
: 678683 (view as bug list)
Depends On:
Blocks: 682679
TreeView+ depends on / blocked
 
Reported: 2010-12-09 15:59 UTC by David Kovalsky
Modified: 2014-03-31 23:46 UTC (History)
4 users (show)

Fixed In Version: claws-mail-3.7.8-6.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-03 03:37:03 UTC


Attachments (Terms of Use)
File: backtrace (74.83 KB, text/plain)
2010-12-09 15:59 UTC, David Kovalsky
no flags Details
patch from claws-mail-3.7.8cvs58 snapshot (1.45 KB, patch)
2011-02-22 18:35 UTC, Michael Schwendt
no flags Details | Diff

Description David Kovalsky 2010-12-09 15:59:20 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: claws-mail
component: claws-mail
crash_function: compose_show_first_last_header
executable: /usr/bin/claws-mail
kernel: 2.6.34.7-63.fc13.x86_64
package: claws-mail-3.7.6-1.fc13
rating: 4
reason: Process /usr/bin/claws-mail was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
time: 1291909210
uid: 10625

How to reproduce
-----
1. Write an email
2. Have several email accounts setup with different signatures and servers.
3. Point the mouse in the new message window to the account name ("From" dropdown menu) and wildly use the mouse scroll as if you we're scrolling a web page.
4. Boom!

Comment 1 David Kovalsky 2010-12-09 15:59:24 UTC
Created attachment 467774 [details]
File: backtrace

Comment 2 Michael Schwendt 2011-01-23 17:21:14 UTC
Not 100% reproducible though. Only once I managed to freeze Claws Mail 3.7.8 on F14. Even with several "wild" attempts I could not crash it.

Comment 3 David Kovalsky 2011-01-23 22:43:24 UTC
Hi Michael, 

just FYI, I've updated to F14 around Christmas and haven't seen the crash since. Even on F13 this was pretty random. I do a lot of emailing as part of my work, still the crash was at most once per week.

Comment 4 Michael Schwendt 2011-02-18 21:31:45 UTC
*** Bug 678683 has been marked as a duplicate of this bug. ***

Comment 5 Michael Schwendt 2011-02-22 18:35:18 UTC
Created attachment 480198 [details]
patch from claws-mail-3.7.8cvs58 snapshot

Even with wild mouse-wheel usage I'm unable to reproduce after applying the patch.

Comment 6 Fedora Update System 2011-02-22 21:25:33 UTC
claws-mail-3.7.8-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/claws-mail-3.7.8-6.fc14

Comment 7 Fedora Update System 2011-02-22 21:26:13 UTC
claws-mail-3.7.8-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/claws-mail-3.7.8-6.fc15

Comment 8 Fedora Update System 2011-02-22 21:27:16 UTC
claws-mail-3.7.8-6.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/claws-mail-3.7.8-6.fc13

Comment 9 Fedora Update System 2011-02-23 20:27:58 UTC
claws-mail-3.7.8-6.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update claws-mail'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/claws-mail-3.7.8-6.fc15

Comment 10 Fedora Update System 2011-03-03 03:36:53 UTC
claws-mail-3.7.8-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-03-04 09:54:11 UTC
claws-mail-3.7.8-6.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-03-04 10:00:03 UTC
claws-mail-3.7.8-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.