Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 661769 - ekiga can't be rebuild in mock because of opal bug
Summary: ekiga can't be rebuild in mock because of opal bug
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: opal
Version: 6.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Benjamin Otte
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-09 16:02 UTC by Levente Farkas
Modified: 2015-10-05 14:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-05 14:24:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
This should fix the bug (401 bytes, patch)
2011-12-21 17:18 UTC, jcpunk
no flags Details | Diff

Description Levente Farkas 2010-12-09 16:02:33 UTC
when building in mock build always failed with this error:


g++ -DHAVE_CONFIG_H -I. -I.. -I../lib -I../lib/gmconf -I../lib/toolbox -I../lib/gui -I../lib/engine/ -I../lib/engine/framework -I../lib/engine/gui/gtk-fronte
nd -I../lib/engine/components/call-history -I../lib/engine/account -I../lib/engine/addressbook -I../lib/engine/chat -I../lib/engine/presence -I../lib/engine/
protocol -I../lib/engine/protocol/sip -I../lib/engine/videooutput -I../lib/engine/videoinput -I../lib/engine/audioinput -I../lib/engine/audiooutput -I../lib/
engine/hal -I../lib/engine/framework -I../lib/engine/gui/gtk-core -I../lib/engine/components/opal -I../src -I../src/dbus-helper/ -I../src/gui/ -I../src/dbus-
helper/  -I../lib/engine/videooutput/common -I../lib/engine/videooutput/x    -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/
include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/li
bpng12   -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include    -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/l
ib/glib-2.0/include    -DPTRACING=1 -D_REENTRANT -D_GNU_SOURCE=1 -fno-exceptions -I/usr/include/opal -I/usr/include/SDL   -DPTRACING=1 -D_REENTRANT -D_GNU_SO
URCE=1 -fno-exceptions -I/usr/include/SDL   -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include   -I/usr/include/libxml2   -I/usr/include/gtk-2.0 -I/usr/
include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/inc
lude/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12   -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fe
xceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -DLDAP_DEPRECATED=1 -fPIC -Wall -Wextra -Wini
t-self -Wswitch-default -Wswitch-enum -Wstrict-aliasing=2 -Wfloat-equal -Wshadow -MT dialpad.o -MD -MP -MF .deps/dialpad.Tpo -c -o dialpad.o `test -f 'gui/di
alpad.cpp' || echo './'`gui/dialpad.cpp
In file included from ./common.h:42,
                 from gui/callbacks.h:43,
                 from gui/callbacks.cpp:42:
/usr/include/opal/opal/buildopts.h:113:2: error: #error "define a proper libdir"
In file included from ./common.h:42,
                 from gui/conf.h:47,
                 from gui/conf.cpp:46:
/usr/include/opal/opal/buildopts.h:113:2: error: #error "define a proper libdir"
mv -f .deps/dialpad.Tpo .deps/dialpad.Po
g++ -DHAVE_CONFIG_H -I. -I.. -I../lib -I../lib/gmconf -I../lib/toolbox -I../lib/gui -I../lib/engine/ -I../lib/engine/framework -I../lib/engine/gui/gtk-fronte
nd -I../lib/engine/components/call-history -I../lib/engine/account -I../lib/engine/addressbook -I../lib/engine/chat -I../lib/engine/presence -I../lib/engine/
protocol -I../lib/engine/protocol/sip -I../lib/engine/videooutput -I../lib/engine/videoinput -I../lib/engine/audioinput -I../lib/engine/audiooutput -I../lib/
engine/hal -I../lib/engine/framework -I../lib/engine/gui/gtk-core -I../lib/engine/components/opal -I../src -I../src/dbus-helper/ -I../src/gui/ -I../src/dbus-
helper/  -I../lib/engine/videooutput/common -I../lib/engine/videooutput/x    -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/
include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/li
bpng12   -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include    -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/l
ib/glib-2.0/include    -DPTRACING=1 -D_REENTRANT -D_GNU_SOURCE=1 -fno-exceptions -I/usr/include/opal -I/usr/include/SDL   -DPTRACING=1 -D_REENTRANT -D_GNU_SO
URCE=1 -fno-exceptions -I/usr/include/SDL   -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include   -I/usr/include/libxml2   -I/usr/include/gtk-2.0 -I/usr/
include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/inc
lude/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12   -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fe
xceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i686 -mtune=atom -fasynchronous-unwind-tables -DLDAP_DEPRECATED=1 -fPIC -Wall -Wextra -Wini
t-self -Wswitch-default -Wswitch-enum -Wstrict-aliasing=2 -Wfloat-equal -Wshadow -MT assistant.o -MD -MP -MF .deps/assistant.Tpo -c -o assistant.o `test -f '
gui/assistant.cpp' || echo './'`gui/assistant.cpp
make[3]: *** [callbacks.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: *** [conf.o] Error 1
mv -f .deps/accounts.Tpo .deps/accounts.Po
mv -f .deps/assistant.Tpo .deps/assistant.Po
make[3]: Leaving directory `/builddir/build/BUILD/ekiga-3.2.6/src'
make[2]: Leaving directory `/builddir/build/BUILD/ekiga-3.2.6/src'
make[2]: *** [all] Error 2
make[1]: Leaving directory `/builddir/build/BUILD/ekiga-3.2.6'
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Comment 2 Levente Farkas 2010-12-21 13:54:40 UTC
any news on this error?

Comment 3 Levente Farkas 2010-12-21 17:06:41 UTC
it seems the problem is with opal's header /usr/include/opal/opal/buildopts.h can't find the definition of __WORDSIZE

which means your patch opal-3.6.6-buildopts.patch not working on rhel-6 (which is strange since it's not on fedora:-)

---------------------------------
/* This only works on Fedora/RHEL.
 * It is required to avoid multilib conflicts */
#if __WORDSIZE == 64
#define  OPAL_PLUGIN_DIR "/usr/lib64/opal-" OPAL_VERSION
#elif __WORDSIZE == 32
#define  OPAL_PLUGIN_DIR "/usr/lib/opal-" OPAL_VERSION
#else
#error "define a proper libdir"
#endif
---------------------------------
from where this __WORDSIZE should have to come? may be you'd have to include it.

Comment 4 merlinchenx 2010-12-22 08:06:14 UTC
(In reply to comment #3)
> it seems the problem is with opal's header /usr/include/opal/opal/buildopts.h
> can't find the definition of __WORDSIZE
> 
> which means your patch opal-3.6.6-buildopts.patch not working on rhel-6 (which
> is strange since it's not on fedora:-)
> 
> ---------------------------------
> /* This only works on Fedora/RHEL.
>  * It is required to avoid multilib conflicts */
> #if __WORDSIZE == 64
> #define  OPAL_PLUGIN_DIR "/usr/lib64/opal-" OPAL_VERSION
> #elif __WORDSIZE == 32
> #define  OPAL_PLUGIN_DIR "/usr/lib/opal-" OPAL_VERSION
> #else
> #error "define a proper libdir"
> #endif
> ---------------------------------
> from where this __WORDSIZE should have to come? may be you'd have to include
> it.
__WORDSIZE comes from /usr/include/bits/wordsize.h which included by sys/types.h,I temporarily solve the problem by including sys/types.h to ekiga/src/common.h.But the ware thing is opal itself compiled without an error in the same mock environment.

Comment 5 Levente Farkas 2010-12-22 09:56:10 UTC
but as the new patch use __WORDSIZE and buildopts.h do NOT include types.h so it's a bug in opal. ie. opal-3.6.6-buildopts.patch should have to add 
#include <types.h> 
to the buildopts.h file.

Comment 6 Levente Farkas 2010-12-22 10:52:30 UTC
i mean:
#include <sys/types.h>

Comment 7 RHEL Program Management 2011-01-07 15:44:48 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 8 jcpunk 2011-12-21 17:18:53 UTC
Created attachment 549057 [details]
This should fix the bug

I've attached a patch which seems to correct the problem

Comment 9 Levente Farkas 2012-12-07 11:43:37 UTC
already fixed


Note You need to log in before you can comment on or make changes to this bug.