Bug 66177 - Erase pre-populated text in "Search Red Hat" box on www.redhat.com
Erase pre-populated text in "Search Red Hat" box on www.redhat.com
Status: CLOSED CURRENTRELEASE
Product: Red Hat Web Site
Classification: Red Hat
Component: Global Header (Show other bugs)
current
i386 Linux
low Severity medium
: ---
: ---
Assigned To: rcabral
Tom Lancaster
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-05 16:56 EDT by mandi
Modified: 2007-03-26 23:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-23 10:32:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mandi 2002-06-05 16:56:20 EDT
Description of Problem:

Search box in global header is populated with text "enter search term" that
remains when user clicks in the box.  The user then has to manually delete this
pre-entered text before entering a search term.

The same applies to the "Your email" box for the "Newsletters" section in the
center of the page.

Version-Release number of selected component (if applicable):


How Reproducible:

go to www.redhat.com
click in the SEARCH RED HAT:  box
or the newsletters/email box.


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:

Pre-populated text remains in the input and must be deleted by the user.

Expected Results:

would be nice if the pre-populated text were to be erased when the user clicked
in the <INPUT>

accomplished by adding a little javascript to the INPUT tag for these text inputs:
onfocus="this.value='';"
or, since that would erase the text everytime the user clicked out and clicked
back into the input box, you could use something like

onfocus="if(this.value == 'enter search term') { this.value='';}"

Additional Information:

Note You need to log in before you can comment on or make changes to this bug.