Bug 661770 - can't be rebuild in mock
can't be rebuild in mock
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: foomatic (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Tim Waugh
Desktop QE
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-09 11:04 EST by Levente Farkas
Modified: 2013-07-18 11:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: foomatic-4.0.4-3.el6
Doc Type: Bug Fix
Doc Text:
Cause: The installation locations for perl files were incorrect in the spec file. Consequence: The package could not be rebuilt. Fix: The installation locations have been fixed. Result: The package can now be rebuilt.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 05:26:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
foomatic-perl.patch (1.52 KB, patch)
2010-12-21 11:06 EST, Tim Waugh
no flags Details | Diff

  None (edit)
Description Levente Farkas 2010-12-09 11:04:51 EST
build always fail in mock with this error:


Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.th4OHJ
+ umask 022
+ cd /builddir/build/BUILD
+ cd foomatic-4.0.4
+ DOCDIR=/builddir/build/BUILDROOT/foomatic-4.0.4-1.el6.i386/usr/share/doc/foomatic-4.0.4
+ export DOCDIR
+ rm -rf /builddir/build/BUILDROOT/foomatic-4.0.4-1.el6.i386/usr/share/doc/foomatic-4.0.4
+ /bin/mkdir -p /builddir/build/BUILDROOT/foomatic-4.0.4-1.el6.i386/usr/share/doc/foomatic-4.0.4
+ cp -pr --parents foomatic-filters-4.0.4/COPYING /builddir/build/BUILDROOT/foomatic-4.0.4-1.el6.i386/usr/share/doc/foomatic-4.0.4
+ cp -pr --parents foomatic-db-engine-4.0.4/COPYING /builddir/build/BUILDROOT/foomatic-4.0.4-1.el6.i386/usr/share/doc/foomatic-4.0.4
+ exit 0
RPM build errors:
    Macro % has illegal name (%define)
    Macro % has illegal name (%define)
    File not found: /builddir/build/BUILDROOT/foomatic-4.0.4-1.el6.i386/usr/share/perl5/Foomatic
Comment 3 Levente Farkas 2010-12-21 08:56:02 EST
can we wait an update for rhel-6 too?
Comment 4 Tim Waugh 2010-12-21 10:27:16 EST
We hope to fix this in a future update to Red Hat Enterprise Linux.  Thank you for reporting it.
Comment 5 Levente Farkas 2010-12-21 10:47:35 EST
and the above patch is wrong for two reason:
- installvendorlib and installvendorarch by default
- INSTALLSITELIB=$RPM_BUILD_ROOT/%{installvendorlib} should have to be INSTALLSITELIB=%{perl_vendorlib} without $RPM_BUILD_ROOT
Comment 6 Tim Waugh 2010-12-21 11:06:49 EST
Created attachment 470016 [details]
foomatic-perl.patch

Thanks.  Here is a new proposed patch based on your suggestion.
Comment 7 Levente Farkas 2010-12-21 11:23:18 EST
that's exactly what i did.
Comment 8 Siddharth Nagar 2011-06-08 21:54:26 EDT
Deferring to RHEL 6.3 for possible inclusion. We are unable to accommodate this for RHEL 6.2.
Comment 11 Suzanne Yeghiayan 2012-02-14 18:05:15 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 16 errata-xmlrpc 2013-07-17 05:26:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1084.html

Note You need to log in before you can comment on or make changes to this bug.