Bug 6618 - apxs installs modules in the wrong place
apxs installs modules in the wrong place
Status: CLOSED DUPLICATE of bug 5650
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
6.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-01 18:20 EST by simon.greaves
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-02 10:56:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description simon.greaves 1999-11-01 18:20:03 EST
Using apxs to install a locally compiled version of php
fails because apxs tries to install it to a 'modules'
directory in the current directory, not into the apache
tree.

The fix I used is to manually edit /usr/sbin/apxs, changing
the line:

my $CFG_LIBEXECDIR    = 'modules';

to:

my $CFG_LIBEXECDIR    = '/usr/lib/apache';

Will email a trivial patch.

Simon
Comment 1 Preston Brown 1999-11-02 10:56:59 EST
*** This bug has been marked as a duplicate of 5650 ***

Note You need to log in before you can comment on or make changes to this bug.