Bug 661804 - can't be rebuilt in mock
can't be rebuilt in mock
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-Test-MockObject (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Petr Pisar
Jan Kepler
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-09 12:04 EST by Levente Farkas
Modified: 2014-01-30 04:21 EST (History)
3 users (show)

See Also:
Fixed In Version: perl-Test-MockObject-1.09-4.el6
Doc Type: Bug Fix
Doc Text:
Cause: Building perl-Test-MockObject source RPM package without installed perl-CGI package. Consequence: Build process fails on executing tests. Fix: Build-time dependencies on CGI, Test::Builder, and Test::More Perl modules have been declared in the RPM package. Result: It's possible to rebuild perl-Test-MockObject source package in minimal environment.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 10:43:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2010-12-09 12:04:38 EST
can't be rebuild in mock because durint %check it need perl-CGI which is not
BR-ed.

Can't locate CGI.pm in @INC (@INC contains: /builddir/build/BUILD/Test-MockObject-1.09/blib/lib /builddir/build/BUILD/Test-MockObject-1.09/blib/arch /builddi
r/build/BUILD/Test-MockObject-1.09/_build/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/li
b64/perl5 /usr/share/perl5 .) at /builddir/build/BUILD/Test-MockObject-1.09/blib/lib/Test/MockObject/Extends.pm line 36.
# Looks like you planned 41 tests but ran 3.
# Looks like your test exited with 2 just after 3.
t/extends.t .................
Dubious, test returned 2 (wstat 512, 0x200)
Failed 38/41 subtests
t/ignore.t .................. ok
t/isa.t ..................... ok
t/developer/pod-coverage.t .. ok
t/developer/pod.t ........... ok
Test Summary Report
-------------------
t/extends.t               (Wstat: 512 Tests: 3 Failed: 0)
  Non-zero exit status: 2
  Parse errors: Bad plan.  You planned 41 tests but ran 3.
Files=9, Tests=178,  0 wallclock secs ( 0.06 usr  0.01 sys +  0.30 cusr  0.05 csys =  0.42 CPU)
Result: FAIL
Failed 1/9 test programs. 0/178 subtests failed.
error: Bad exit status from /var/tmp/rpm-tmp.Di7YXW (%check)
RPM build errors:
    Macro % has illegal name (%define)
    Macro % has illegal name (%define)
    Bad exit status from /var/tmp/rpm-tmp.Di7YXW (%check)
Comment 2 Petr Pisar 2010-12-09 12:42:04 EST
perl(CGI) has been splitted from main perl package after last build of this package. Simple add `BuildRequire: perl(CGI)' is enough. This will be fixed once rebuild of this package will be needed for other reasons.
Comment 4 RHEL Product and Program Management 2011-01-07 10:30:49 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 5 RHEL Product and Program Management 2011-07-05 19:42:08 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 16 errata-xmlrpc 2013-05-20 10:43:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0836.html

Note You need to log in before you can comment on or make changes to this bug.