Bug 66186 - DHCP disrupts X
DHCP disrupts X
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-05 18:59 EDT by josip
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-05 18:59:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description josip 2002-06-05 18:59:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
When DHCP client gets a new IP/hostname, X windows server refuses to open any
new windows (e.g. a new X terminal).  Apparently, when dhcpcd reconfigures the
machine's address and hostname, it does not adjust X server access accordingly.

Suggestion: automatically run xhost with the new hostname upon DHCP renewal as
needed

Version-Release number of selected component (if applicable):
dhcpcd-1.3.22pl1-7

How reproducible:
Always

Steps to Reproduce:
1.use dhcpcd to configure machine named 'localhost'
2.dhcpcd gets DHCP info, renames machine to 'somehost.somedomain'
3.after a long time, dhcpcd gets changed DHCP info, renames machine to
'otherhost.somedomain'
4. X server (running since step 1) refuses to open any new windows
	

Actual Results:  X refused access to all newly started local applications

Expected Results:  X should have recognized that the new hostname
'otherhost.somedomain' is authorized after step 2.

Additional info:
Comment 1 Elliot Lee 2002-06-05 19:06:03 EDT
This is really the fault of the DHCP server changing network info for a running
system. There are apps such as X, CORBA, etc. that require the hostname <-> IP
mapping to stay the same. I don't think it's possible or prudent to eliminate
this requirement.

The suggested workarounds would be either to fix the DHCP server to not to
change the hostname for an outstanding lease, or to set the hostname on each
machine to localhost (or any other hostname for which the hostname <-> IP
mapping stays constant for the life of the system).

Note You need to log in before you can comment on or make changes to this bug.