Bug 661899 - cannot set list-o-map entry - bad validation
cannot set list-o-map entry - bad validation
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
3.0.0
Unspecified Unspecified
urgent Severity urgent (vote)
: ---
: ---
Assigned To: Ian Springer
Corey Welton
:
Depends On:
Blocks: rhq4 config/individual-config
  Show dependency treegraph
 
Reported: 2010-12-09 17:28 EST by John Mazzitelli
Modified: 2013-08-05 20:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
validation.png (18.67 KB, image/png)
2010-12-09 17:29 EST, John Mazzitelli
no flags Details

  None (edit)
Description John Mazzitelli 2010-12-09 17:28:09 EST
In the configuration editor, I'm trying to edit a field in a list-o-map property and its not letting me set a value although its telling me "field is required".

Specifically:

1) go to an agent resource
2) go to its connection properties subtab
3) click the edit icon (a pencil in the 4.0.0.DP2 version) for one of the event sources (in my tests, I want to enable the agent.log event source)
4) you get the popup dialog window titled "Edit Configuration Row" - try to click the "Yes" radio button for the "Enabled" property.

Even though "No" was already the value, the UI is not letting me select "Yes" and the validation error icon pops up telling me "field is required".

See the attached snapshot - validation.png
Comment 1 John Mazzitelli 2010-12-09 17:29:00 EST
Created attachment 467862 [details]
validation.png
Comment 2 John Mazzitelli 2011-03-14 12:31:28 EDT
setting to urgent, this needs to be a blocker issue because you can't flip boolean settings in config
Comment 3 Ian Springer 2011-03-14 13:57:58 EDT
Worked around by not validating the map every time a member prop's value is changed - [master b799282].
Comment 4 Sunil Kondkar 2011-04-05 06:59:18 EDT
Verified on build#1123  (Version: 4.0.0-SNAPSHOT Build Number: 08da74a)

Clicking the "Yes" radio button for the "Enabled" property selects the 'Yes' radio button. No validation error/icon is observed.
Also verified by changing values from Yes to No and No to Yes.

Marking as verified.
Comment 5 Corey Welton 2011-05-23 21:13:35 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:13:38 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 7 Corey Welton 2011-05-23 21:13:38 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.