Bug 6619 - Install docs missing disk space and swap guidance
Install docs missing disk space and swap guidance
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rhl-ig-x86 (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sandra Moore
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-01 18:34 EST by Joe Harrington
Modified: 2014-08-04 18:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-21 10:52:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Harrington 1999-11-01 18:34:28 EST
Partitioning happens before package selection,
                          But,
Package selection says how big partitions need to be.

Manuals are great at resolving this sort of thing.

There are acres of paper devoted to running druid, but
almost nothing on recommendations for how big to make the
partitions.  I just got off the phone with a colleague who
has installed 6.1 several times, each time trying different
partitionings to get one to work.  Clearly he's new, but the
point is that so are most users.

Recommendation:
1. In the paper manual give the default partition sizes and
package selection for all the "canned" setups (KDE/GNOME ws,
server, etc.).  Describe in words what you do and don't get
and the difference in appearance to the user.

1a. Discuss the difference between KDE and GNOME!

2. In the manual, say what the total space used by all
packages is, if all are installed, and also the total space
used by each group of packages.

3. Offer guidance on putting /usr in the same partition as /
vs. keeping them separate, and say how big each should be if
they're separate.  Ditto /var and /usr/local.  Recommend
that they make a symlink /var -> /home/var so that mail
isn't blown away with a reinstall.  There's lots of old
fogies still using Mail and storing in their /var/spool
mailbox.

4. The install docs should say more about why to have a
larger or smaller swap space.  Also, I saw no mention of the
128MB swap space limit.  This is bad.  If the limit is gone,
SAY SO, so that we don't have to spend an hour scouring the
manuals to see if it's gone or not.  If it's not gone, then
definitely say so!

Thanks, and thanks for thinking of us in the IPO!

--jh--
Comment 1 Sandra Moore 2000-08-21 10:51:31 EDT
Most of these suggestions have been taken care of in Red Hat Linux 6.2/7.0
documentation. However, since these are just suggestions and not show-stopping,
must be fixed now bugs, I am closing this out.  Thanks for the feedback.  Other
feedback may be sent to docs@redhat.com.
Comment 2 Ed Bailey 2000-08-21 10:57:26 EDT
Thanks for the feedback.  Some of these issues are addressed in our more recent
documentation; the rest, we will consider for future releases.  Thanks again for
the feedback!

Ed

Note You need to log in before you can comment on or make changes to this bug.