Bug 66193 - Metacity unusable on pen/tablet PC
Metacity unusable on pen/tablet PC
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-05 19:55 EDT by Alan Cox
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-02 18:15:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2002-06-05 19:55:23 EDT
Metacity places the maximise/minimise buttons adjacent to the close button and
also lacks an "are you sure" dialog for close. Due to the jitter on pen based
systems this makes it impossible to use on current and upcoming pen based
devices. This is a pity because the rest of the chunky gnome theme in use is
working very well with a touchscreen device.
.
Comment 1 Havoc Pennington 2002-06-05 20:34:33 EDT
There's an open bug on bugzilla.gnome.org to make the buttons relocatable. 
An "are you sure" dialog doesn't work so well since many apps will also have one - 
users would be asked twice. Is that needed if the buttons are moved?
Comment 2 Alan Cox 2002-06-06 05:12:55 EDT
If the buttons are moved its definitely not needed. The problem I found was that
the pens all "jitter" so 99% of the time you hit the right button but the other
1% of the time you press down as the touchpad goes for one of its more wild
samples and pop there goes gnome-terminal.

PS: new gnome-terminal dialogs in gnome2 are *wonderful*
Comment 3 Havoc Pennington 2002-08-07 17:53:47 EDT
I extended the theme format to allow this, so we can add the option 
to move buttons compatibly.
Comment 4 Havoc Pennington 2003-01-02 18:15:40 EST
The buttons are now movable, via a configuration option, though some themes
don't handle it well, some do. In any case remaining bugs should be theme bugs.
Comment 5 Alan Cox 2003-01-02 18:36:50 EST
Thanks a lot

Note You need to log in before you can comment on or make changes to this bug.