Bug 661939 - dhcp primary server keeps outputing "lease imbalance" messages
Summary: dhcp primary server keeps outputing "lease imbalance" messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcp
Version: 5.7
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Jiri Popelka
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-10 02:52 UTC by Masahiro Matsuya
Modified: 2018-11-14 17:35 UTC (History)
5 users (show)

Fixed In Version: dhcp-3.0.5-27.el5
Doc Type: Bug Fix
Doc Text:
Previously, when the dhcpd service was used in a failover configuration, the primary server sometimes wrote so many "lease imbalance" messages into its log files, that it resulted in a termination. With this update, these messages are not logged unless rebalance is attempted, and the bug no longed occurs.
Clone Of:
Environment:
Last Closed: 2011-07-21 10:58:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
backported patch (1.63 KB, patch)
2010-12-10 02:52 UTC, Masahiro Matsuya
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1038 0 normal SHIPPED_LIVE dhcp bug fix and enhancement update 2011-07-20 15:43:54 UTC

Description Masahiro Matsuya 2010-12-10 02:52:10 UTC
Created attachment 467897 [details]
backported patch

Description of problem:
A customer are using dhcpd in a failover configuration and the primary server cannot handle any requests by a message flood. The primary server shows lots of "lease imbalance" messages in the logs and dies without core file or any syslog messages.

The problem is described in <http://marc.info/?l=dhcp-users&m=118851702131444&w=2> (for version 3.06 of dhcpd) and seems to be fixed in version 3.1. See http://marc.info/?l=dhcp-users&m=118893179113440&w=2 and http://www.isc.org/files/release-notes/31esv.html 

The issue was solved with version 3.0.7 : 
  http://dhcp.me/archives/1-ISC-DHCP-3.0.7-has-been-released!.html 

I backported this and the customer tested it. As a result, they confirmed this problem was fixed. I'll attach the backported patch.

Version-Release number of selected component (if applicable):
dhcp-3_0_5-23.el5

How reproducible:
Always

Steps to Reproduce:
At this time, no responsible method to reproduce it.
  
Actual results:
primary server outputs a large amount of messages and cannot provide the services.

Expected results:
primary server doesn't output a large amount of messages and keeps providing the services fine.

Comment 1 Jiri Popelka 2010-12-10 14:25:03 UTC
Thank you, Masahiro !

Comment 11 Tomas Capek 2011-05-31 08:18:08 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, when the dhcpd service was used in a failover configuration, the primary server sometimes wrote so many "lease imbalance" messages into its log files, that it resulted in a termination. With this update, these messages are not logged unless rebalance is attempted, and the bug no longed occurs.

Comment 13 errata-xmlrpc 2011-07-21 10:58:56 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1038.html


Note You need to log in before you can comment on or make changes to this bug.