Bug 661996 - find_package(KDE4 REQUIRED) fails in cmake with qt3-devel installed
find_package(KDE4 REQUIRED) fails in cmake with qt3-devel installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
: Regression, Reopened
Depends On:
Blocks: 661075
  Show dependency treegraph
 
Reported: 2010-12-10 04:47 EST by Akira TAGOH
Modified: 2010-12-10 14:06 EST (History)
9 users (show)

See Also:
Fixed In Version: 4.5.85-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-10 14:06:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simple CMakeLists.txt to reproduce this issue (121 bytes, text/plain)
2010-12-10 04:51 EST, Akira TAGOH
no flags Details

  None (edit)
Description Akira TAGOH 2010-12-10 04:47:19 EST
Description of problem:
cmake complains "qmake not found".

Version-Release number of selected component (if applicable):
kdelibs-devel-4.5.85-1.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1.run cmake on you've put the attached CMakeLists.txt on.
2.
3.
  
Actual results:
$ cmake .
CMake Error at /usr/share/kde4/apps/cmake/modules/FindQt4.cmake:1262 (MESSAGE):
  Qt qmake not found!
Call Stack (most recent call first):
  /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:417 (find_package)
  /usr/share/cmake/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
  CMakeLists.txt:3 (find_package)

Expected results:
no errors.

Additional info:
This worked before. I'm not sure what changed in anywhere, but simply creating a symlink of qmake-qt4 to qmake works again. so does cmake not check qmake-qt4 anymore?

For the real problem on this issue, see Bug#661075.
Comment 1 Akira TAGOH 2010-12-10 04:51:03 EST
Created attachment 467939 [details]
simple CMakeLists.txt to reproduce this issue

Doh! missed the attached.
Comment 2 Jaroslav Reznik 2010-12-10 10:37:42 EST
Works for me with kdelibs-devel-4.5.85-2.fc15.x86_64 (upstream tarball respin).
Comment 3 Kevin Kofler 2010-12-10 10:42:46 EST
Please retry with both qt-devel and qt3-devel installed (which is the case in the buildroot for uim).

Apparently /usr/share/kde4/apps/cmake/modules/FindQt4.cmake now accidentally picks up the Qt 3 qmake, there must be a regression there.
Comment 4 Kevin Kofler 2010-12-10 12:10:24 EST
We need this merged from upstream CMake:
http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=cfba5ef111bf86e8820a4dff556b3a9edc1484cd
(also into upstream kdelibs).

KDE upstream merged:
http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=2dae2f1a0b24c674b651fd6edf79c4b51177b4d6
and forgot to merge the followup regression fix.
Comment 5 Kevin Kofler 2010-12-10 12:38:50 EST
Should be fixed in kdelibs-4.5.85-3.fc15 and in upstream trunk (to become 4.6, there's no 4.6 branch yet).
Comment 6 Kevin Kofler 2010-12-10 14:06:52 EST
2657364 build (dist-rawhide, /kdelibs:9d96f580c295605cf53f28560b9912923711062c) completed successfully

Note You need to log in before you can comment on or make changes to this bug.