Bug 662039 - PyQwt/sip broken in rawhide
PyQwt/sip broken in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sip (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 660947 (view as bug list)
Depends On:
Blocks: 660947
  Show dependency treegraph
 
Reported: 2010-12-10 07:14 EST by Susi Lehtola
Modified: 2010-12-10 18:44 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-10 13:43:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Susi Lehtola 2010-12-10 07:14:39 EST
I'm trying to build PyMca in rawhide. It builds fine in Fedora 14, but the build segfaults in rawhide.

I've traced this back to

running build_scripts
==1224== Invalid read of size 8
==1224==    at 0xD8108E5: ??? (in /usr/lib64/python2.7/site-packages/sip.so)
==1224==    by 0xD8112A7: ??? (in /usr/lib64/python2.7/site-packages/sip.so)
==1224==    by 0xEFA5485: initQwt (in /usr/lib64/python2.7/site-packages/PyQt4/Qwt5/Qwt.so)
==1224==    by 0x4F2CE24: _PyImport_LoadDynamicModule (in /usr/lib64/libpython2.7.so.1.0)
==1224==    by 0x4F2B0DE: ??? (in /usr/lib64/libpython2.7.so.1.0)
==1224==    by 0x4F2B373: ??? (in /usr/lib64/libpython2.7.so.1.0)
==1224==    by 0x4F2B9E4: ??? (in /usr/lib64/libpython2.7.so.1.0)
==1224==    by 0x4F2BFA9: PyImport_ImportModuleLevel (in /usr/lib64/libpython2.7.so.1.0)
==1224==    by 0x4F100AE: ??? (in /usr/lib64/libpython2.7.so.1.0)
==1224==    by 0x4E76FC2: PyObject_Call (in /usr/lib64/libpython2.7.so.1.0)
==1224==    by 0x4F11A86: PyEval_CallObjectWithKeywords (in /usr/lib64/libpython2.7.so.1.0)
==1224==    by 0x4F152E0: PyEval_EvalFrameEx (in /usr/lib64/libpython2.7.so.1.0)
==1224==  Address 0x0 is not stack'd, malloc'd or (recently) free'd
Comment 1 Kevin Kofler 2010-12-10 10:20:19 EST
Do we need PyQwt rebuilt for Rawhide maybe?
Comment 2 Rex Dieter 2010-12-10 12:28:58 EST
OK, couldn't hurt, rebuilding now PyQwt now.
Comment 3 Rex Dieter 2010-12-10 13:43:58 EST
that seems to have done the trick, the requeued PyMca build finished ok now,
https://koji.fedoraproject.org/koji/taskinfo?taskID=2657425
Comment 4 Susi Lehtola 2010-12-10 18:44:47 EST
*** Bug 660947 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.