Bug 66205 - Konqueror download status does not close
Konqueror download status does not close
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-06 05:21 EDT by Warren Togami
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-08 23:35:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-06-06 05:21:57 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux) 
 
Description of problem: 
When you download a file (like an rpm package) with Konqueror, the download 
status dialogue doesn't disappear when the transfer is complete.  It is stuck 
at 99% or 100% with 1 second estimated time left, and the Cancel button is 
still there.  You can tell the file download was complete because it already 
renamed the file to the actual name rather than the partial hidden dotfile 
name that it uses during transfer. 
 
Version-Release number of selected component (if applicable): 
Red Hat Linux 7.3 
KDE 3.0.0-12 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Download any file like an RPM package 
2. Allow the file transfer to finish 
 
Actual Results:   
Gives no visual feedback that the transfer completed. 
 
Expected Results:   
It should either close the download dialogue window, or somehow indicate that 
it finished the transfer and change the Cancel button to Close.
Comment 1 Ben Levenson 2002-06-11 13:27:25 EDT
I can't reproduce this.
Comment 2 Warren Togami 2002-07-10 08:30:24 EDT
I have just experienced it on another fresh install of Red Hat 7.3 today.  It
seems to be intermittent... occured twice today, once with an RPM and once with
an OGG.

http://www.uhband.hawaii.edu/recording.htm
The OGGs were from this page.
Comment 3 Warren Togami 2002-07-12 09:54:59 EDT
Occured in Limbo beta once out of 15 downloads.  I still can't figure out how to
trigger this behavior consistently.
Comment 4 Warren Togami 2003-03-15 04:08:00 EST
Still happens in kdebase-3.1-9 in Phoebe3.  Occurs often with that same OGG
download page mentioned above.
Comment 5 Warren Togami 2003-04-03 00:56:02 EST
Still happens in kdebase-3.1-12
Comment 6 Ali-Reza Anghaie 2003-04-13 20:54:25 EDT
I can't reproduce this with RHL 9 with the same kdebase as you last specified. Can you give a 
few URLs that you run into this with? Does Kget try to automagically run for you as well? 
 
Comment 7 Warren Togami 2003-04-13 21:10:16 EDT
If your konqueror is set to close the download window when complete this doesn't happen.  If it 
is set to keep the window open, then very often (but not always) it stops at 99% with a 
complete file and "Cancel" button is still there. 
 
It happens almost every time with the OGGs on that page above, and downloading Java 
rpm.bin files from http://www.javasoft.com. 
 
This behavior has been this way since KDE 2.2.x, perhaps earlier. 
 
Comment 8 Ali-Reza Anghaie 2003-04-13 21:24:02 EDT
I can't reproduce this. Are you, by chance, using upgrade on upgrade? So you've moved from 
KDE 2 -> 3 -> 3.1 with the same configs? 
Comment 9 Warren Togami 2003-04-13 21:45:15 EDT
Nope, I never do upgrades.  These are all fresh installs on a dozen different
systems with different versions of Red Hat Linux over the years.

Like I said, it doesn't happen all the time.
Comment 10 Warren Togami 2004-03-08 23:35:05 EST
Seems okay now. 

Note You need to log in before you can comment on or make changes to this bug.