Bug 662063 - seamonkey.i686 does not run on Fedora 14 x86_64
Summary: seamonkey.i686 does not run on Fedora 14 x86_64
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: seamonkey
Version: 14
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-10 13:44 UTC by Louis van Dyk
Modified: 2010-12-22 14:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-22 13:29:15 UTC


Attachments (Terms of Use)
Output of "strace seamonkey" (33.92 KB, text/plain)
2010-12-10 13:44 UTC, Louis van Dyk
no flags Details

Description Louis van Dyk 2010-12-10 13:44:09 UTC
Created attachment 467971 [details]
Output of "strace seamonkey"

Description of problem:
I use seamonkey to run java i386 for my Juniper Networks VPN app.  I upgraded Fedora 12 to Fedora 14 using preupgrade.  Now, seamonkey.i686 will not run on Fedora 14 x86_64.  I have uninstalled and reinstalled it without luck. If I install seamonkey x86_64, it works.  I even deleted .mozilla/seamonkey - no change.  If I run it from the command line, I immediately go back to the command prompt.  

I will attach an strace of the command.

Version-Release number of selected component (if applicable):
seamonkey-2.0.8-1.fc14.i686

How reproducible:
Every time.

Steps to Reproduce:
1.  Run Fedora 12 x86_64.  
2.  Install Seamonkey i686.
3.  Upgrade directly to Fedora 14 using preupgrade.
4.  Seamonkey no longer runs.
5.  Yum erase seamonkey; yum install seamonkey.i686. No luck.
6.  Yum erase seamonkey; yum install seamonkey.x86_64. It works.
7.  Yum erase seamonkey; yum install seamonkey.i686. No luck.
  
Actual results:
seamonkey does not start

Expected results:
seamonkey should start and run and be usable

Additional info:

Comment 1 Louis van Dyk 2010-12-21 15:56:21 UTC
I have just upgraded to seamonkey-2.0.11-1.fc14.i686.  Sadly, the problem remains the same.

Comment 2 Louis van Dyk 2010-12-22 13:29:15 UTC
During the course of things, I decided to erase Avast Antivirus (i386) from my x86_64 Fedora 14 (which as I stated had been upgraded from Fedora 12).

Using yum, this is what was deleted:
===============================================================================================================================================================================================================
 Package                                      Arch                            Version                                       Repository                                                                    Size
===============================================================================================================================================================================================================
Removing:
 avast4server                                 i586                            3.0.1-1                                       @/avast4server-3.0.1-1.i586/12                                               567 k
 avast4workstation                            i586                            1.3.0-1                                       @/avast4workstation-1.3.0-1.i586/11                                           41 M
 libavastengine                               i586                            4.7.4-1                                       @/libavastengine-4.7.4-1.i586/12                                              17 M
Removing for dependencies:
 gnome-keyring                                i686                            2.32.1-1.fc14                                 @anaconda-InstallationRepo-201010211827.x86_64                               5.1 M
 gtk2                                         i686                            2.22.0-1.fc14.1                               @anaconda-InstallationRepo-201010211827.x86_64                                13 M
 libbonoboui                                  i686                            2.24.4-1.fc14                                 @anaconda-InstallationRepo-201010211827.x86_64                               1.2 M
 libglade2                                    i686                            2.6.4-3.fc12                                  @anaconda-InstallationRepo-200911081904.x86_64/12                            139 k
 libgnomecanvas                               i686                            2.30.2-1.fc14                                 @anaconda-InstallationRepo-201010211827.x86_64                               925 k
 libgnomeui                                   i686                            2.24.4-1.fc14                                 @anaconda-InstallationRepo-201010211827.x86_64                               3.1 M
 seamonkey                                    i686                            2.0.11-1.fc14                                 @updates-testing-i386                                                         53 M

Transaction Summary
===============================================================================================================================================================================================================
Remove       10 Package(s)


Then, I needed seamonkey, so I added it back again, and noticed that two other packages came with it:

Dependencies Resolved

===============================================================================================================================================================================================================
 Package                                           Arch                                       Version                                                  Repository                                         Size
===============================================================================================================================================================================================================
Installing:
 seamonkey                                         i686                                       2.0.8-1.fc14                                             fedora-i386                                        31 M
Installing for dependencies:
 gdk-pixbuf2                                       i686                                       2.22.0-1.fc14                                            fedora                                            491 k
 gtk2                                              i686                                       2.22.0-1.fc14.1                                          fedora                                            3.3 M

Transaction Summary
===============================================================================================================================================================================================================
Install       3 Package(s)


Now, when I ran Seamonkey, it asked to import the settings from Seamonkey 1.x, which it did, and is now working!


Note You need to log in before you can comment on or make changes to this bug.