Bug 662144 - SELinux is preventing /usr/sbin/certmonger "getattr" access on /etc/httpd/alias/secmod.db.
Summary: SELinux is preventing /usr/sbin/certmonger "getattr" access on /etc/httpd/ali...
Keywords:
Status: CLOSED DUPLICATE of bug 662143
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: Unspecified
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-10 18:21 UTC by Dmitri Pal
Modified: 2010-12-10 20:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-10 20:48:59 UTC


Attachments (Terms of Use)

Description Dmitri Pal 2010-12-10 18:21:44 UTC
Summary:

SELinux is preventing /usr/sbin/certmonger "getattr" access on
/etc/httpd/alias/secmod.db.

Detailed Description:

SELinux denied access requested by certmonger. It is not expected that this
access is required by certmonger and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:certmonger_t:s0
Target Context                unconfined_u:object_r:httpd_config_t:s0
Target Objects                /etc/httpd/alias/secmod.db [ file ]
Source                        certmonger
Source Path                   /usr/sbin/certmonger
Port                          <Unknown>
Host                          lenovo.home
Source RPM Packages           certmonger-0.32-0.2010113022gitc2be99c.fc13
Target RPM Packages           mod_nss-1.0.8-6.fc13
Policy RPM                    selinux-policy-3.7.19-74.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     lenovo.home
Platform                      Linux lenovo.home 2.6.34.7-63.fc13.i686 #1 SMP Fri
                              Dec 3 12:35:44 UTC 2010 i686 i686
Alert Count                   15
First Seen                    Fri 10 Dec 2010 01:12:30 PM EST
Last Seen                     Fri 10 Dec 2010 01:13:15 PM EST
Local ID                      ab616cac-b065-4bf0-8a79-1125f19d7f61
Line Numbers                  

Raw Audit Messages            

node=lenovo.home type=AVC msg=audit(1292004795.561:64588): avc:  denied  { getattr } for  pid=14179 comm="certmonger" path="/etc/httpd/alias/secmod.db" dev=dm-0 ino=263086 scontext=unconfined_u:system_r:certmonger_t:s0 tcontext=unconfined_u:object_r:httpd_config_t:s0 tclass=file

node=lenovo.home type=SYSCALL msg=audit(1292004795.561:64588): arch=40000003 syscall=195 success=no exit=-13 a0=9961c70 a1=bfdf1a0c a2=297ff4 a3=3 items=0 ppid=14128 pid=14179 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="certmonger" exe="/usr/sbin/certmonger" subj=unconfined_u:system_r:certmonger_t:s0 key=(null)

Comment 1 Dmitri Pal 2010-12-10 18:28:09 UTC
The issue is found during IPA installation.

Comment 2 Daniel Walsh 2010-12-10 20:48:59 UTC

*** This bug has been marked as a duplicate of bug 662143 ***


Note You need to log in before you can comment on or make changes to this bug.