Bug 662149 - SELinux is preventing /usr/sbin/certmonger "dac_override" access .
Summary: SELinux is preventing /usr/sbin/certmonger "dac_override" access .
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: Unspecified
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-10 18:25 UTC by Dmitri Pal
Modified: 2011-02-02 19:26 UTC (History)
2 users (show)

Fixed In Version: selinux-policy-3.7.19-80.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-21 23:59:14 UTC


Attachments (Terms of Use)

Description Dmitri Pal 2010-12-10 18:25:14 UTC
Summary:

SELinux is preventing /usr/sbin/certmonger "dac_override" access .

Detailed Description:

SELinux denied access requested by certmonger. It is not expected that this
access is required by certmonger and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:certmonger_t:s0
Target Context                unconfined_u:system_r:certmonger_t:s0
Target Objects                None [ capability ]
Source                        certmonger
Source Path                   /usr/sbin/certmonger
Port                          <Unknown>
Host                          lenovo.home
Source RPM Packages           certmonger-0.32-0.2010113022gitc2be99c.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-74.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     lenovo.home
Platform                      Linux lenovo.home 2.6.34.7-63.fc13.i686 #1 SMP Fri
                              Dec 3 12:35:44 UTC 2010 i686 i686
Alert Count                   576
First Seen                    Fri 10 Dec 2010 01:11:49 PM EST
Last Seen                     Fri 10 Dec 2010 01:26:29 PM EST
Local ID                      24b2284b-7cdb-4ace-b19a-ef90d4669dea
Line Numbers                  

Raw Audit Messages            

node=lenovo.home type=AVC msg=audit(1292005589.876:64809): avc:  denied  { dac_override } for  pid=16173 comm="certmonger" capability=1  scontext=unconfined_u:system_r:certmonger_t:s0 tcontext=unconfined_u:system_r:certmonger_t:s0 tclass=capability

node=lenovo.home type=AVC msg=audit(1292005589.876:64809): avc:  denied  { dac_read_search } for  pid=16173 comm="certmonger" capability=2  scontext=unconfined_u:system_r:certmonger_t:s0 tcontext=unconfined_u:system_r:certmonger_t:s0 tclass=capability

node=lenovo.home type=SYSCALL msg=audit(1292005589.876:64809): arch=40000003 syscall=5 success=no exit=-13 a0=9966620 a1=242 a2=180 a3=99666b0 items=0 ppid=14128 pid=16173 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="certmonger" exe="/usr/sbin/certmonger" subj=unconfined_u:system_r:certmonger_t:s0 key=(null)

Comment 1 Dmitri Pal 2010-12-10 18:28:11 UTC
The issue is found during IPA installation.

Comment 2 Daniel Walsh 2010-12-10 20:48:33 UTC
Miroslav, Add them.  Since certmonger can be setup to watch random certificate files, that can be owned by different uids, this is going to be needed.

Comment 3 Miroslav Grepl 2010-12-15 14:05:47 UTC
Fixed in selinux-policy-3.9.7-17.fc14

Comment 4 Fedora Update System 2010-12-16 15:54:26 UTC
selinux-policy-3.9.7-18.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.7-18.fc14

Comment 5 Fedora Update System 2010-12-17 08:36:38 UTC
selinux-policy-3.9.7-18.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/selinux-policy-3.9.7-18.fc14

Comment 6 Dmitri Pal 2010-12-17 17:38:18 UTC
Please build for F13 too.

Comment 7 Miroslav Grepl 2010-12-20 13:56:31 UTC
Fixed in selinux-policy-3.7.19-77.fc13.

Comment 8 Fedora Update System 2010-12-20 18:37:25 UTC
selinux-policy-3.7.19-77.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/selinux-policy-3.7.19-77.fc13

Comment 9 Fedora Update System 2010-12-21 23:58:31 UTC
selinux-policy-3.9.7-18.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-02-02 19:26:07 UTC
selinux-policy-3.7.19-80.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.