Bug 66224 - 7.3 Installer crashes while adding packages
7.3 Installer crashes while adding packages
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-06 11:34 EDT by Greg House
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-06 12:30:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda installation failure log (80.72 KB, text/plain)
2002-06-06 11:35 EDT, Greg House
no flags Details

  None (edit)
Description Greg House 2002-06-06 11:34:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
During both an initial installation, and an upgrade from 7.2, anaconda fails 
with an exception, producing a traceback (attached). During the installation, 
it appears to be after the packages for CD 2 have been installed, but before 
prompted for CD 3. During the upgrade, it occurs after OpenJade is installed 
from CD 1.

RedHat 7.2 installs on this system without issue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from Installation CD 1, both gui and text mode were tested
2. Select English, default keyboard, MS Intellimouse ps/2.
3. Select Install -> Workstation.
4. Select automatic partitioning (other options were tested too).
5. grub bootloader, in MBR, default boot image, no grub password.
6. uncheck DHCP, add IP addr, netmask, hostname, etc.
7. no firewall (other options also tested)
8. English USA, timezone Central, add root password, add one user acct.
9. select gnome, kde, development, and games, no indiv. pkgs (but indiv pkgs 
was tested once).
10. Matrox Mystique autodetected.
11. Wait while FSes are formatted and pkgs are installed.
12. Replace CD 1 with CD 2, wait while CD 2 pkgs installed.
13. Anaconda fails with traceback just before when CD 3 would be requested.
	

Actual Results:  Anaconda fails with traceback just before when CD 3 would be 
requested.


Expected Results:  Installation would prompt for CD 3, install pkgs from there, 
and complete successfully.

Additional info:

Reported to customer support as service request 207134. I was instructed to 
submit a bugzilla report.

Installation media (box set purchased from CompUSA) has been verified using the 
mediacheck boot option (on the system which fails the installation). All three 
install CDs passed.

Performing installation in text mode, and with skip XF86 setup checked, and it 
fails in the same place.

Installed from RH 7.2 CDs. Then attempted to upgrade 7.2 to 7.3, and got a 
similar crash in anaconda (earlier in the process though, while it was 
installing from the first CD).

I used the same RH 7.3 CDs to install on another system as a test, and the 
installation was successful there. 

The system that fails has the following components: 

Abit KR7A motherboard
Athlon XT1800 CPU
1GB of DDR-RAM (2 sticks of 512MB)
Generic floppy
Seagate ST320414A HDD (20GB, 7200RPM, ATA-100, master on IDE1, only device on 
bus)
LG CD-RW CED-8080B (master on IDE2)
generic 48x ATAPI CD (slave on IDE2) 
1.44MB floppy
Matrox Mystique PCI video card
3Com 3C905C-TXM NIC
Ensoniq AudioPCI soundcard

The log from the gui installation failure is attached to customer support 
service request 207134. If necessary, I can provide logs from the text and 
upgrade failures as well.
Comment 1 Greg House 2002-06-06 11:35:57 EDT
Created attachment 59864 [details]
anaconda installation failure log
Comment 2 Greg House 2002-06-06 11:38:03 EDT
Also: I have attempted the installation from both the generic CDROM drive and 
the CD-RW drive with the same results (fails in the same location).
Comment 3 Michael Fulbright 2002-06-06 11:48:55 EDT
Have you run the mediacheck option yet?

Look at:

http://people.redhat.com/~msf/mediacheck.html
Comment 4 Greg House 2002-06-06 11:53:49 EDT
Yes, I ran the boot mediacheck. All three CDs passed. (That was in the original 
problem description...)
Comment 5 Michael Fulbright 2002-06-06 12:30:30 EDT
Sorry, I missed that information.

If you try a minimum install (try 'Custom', then turn off everything in the
screen with all the different package groups) does it do better?

This looks like a media related issue.  It is possible at times that the
read errors happen sporatically (we get about 5-10 bad CD reports a day, though
most of these are due to CDs people have burned themselves).
Comment 6 Greg House 2002-06-06 17:54:43 EDT
It figures that the day I finally submit the thing as a bug, after fighting this
for 4 days, having performed close to 15 installations which all resulted in the
bug, now...I can't recreate it any more.

It appears that this was a result of BIOS issues with my machine. I had
previously selected default bios configuration that it considered "Optimal
Default Settings". This time I selected "Failsafe Default Settings". My next
installation was successful. So I put it back to Optimal settings and...it was
still successful. I can't make it fail now. 

Sorry for wasting your time.

Greg

Note You need to log in before you can comment on or make changes to this bug.