Bug 662252 - [abrt] rhythmbox-0.13.1-2.fc14: rb_ipod_db_get_mount_path: Process /usr/bin/rhythmbox was killed by signal 11 (SIGSEGV)
Summary: [abrt] rhythmbox-0.13.1-2.fc14: rb_ipod_db_get_mount_path: Process /usr/bin/r...
Keywords:
Status: CLOSED DUPLICATE of bug 701746
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c612ed03dbb2786b56c8c8f19b1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-11 01:52 UTC by Joe Buckley
Modified: 2012-03-21 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-21 16:50:29 UTC


Attachments (Terms of Use)
File: backtrace (35.70 KB, text/plain)
2010-12-11 01:52 UTC, Joe Buckley
no flags Details

Description Joe Buckley 2010-12-11 01:52:33 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/rhythmbox
component: rhythmbox
crash_function: rb_ipod_db_get_mount_path
executable: /usr/bin/rhythmbox
kernel: 2.6.35.9-64.fc14.x86_64
package: rhythmbox-0.13.1-2.fc14
rating: 4
reason: Process /usr/bin/rhythmbox was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1292031839
uid: 500

comment
-----
My main concern is not the crash - I'm not convinced a sync operation was appropriate (but of course, it should not have crashed regardless).
But the fact that even though the shuffle was mounted and the files are detected by Fedora and Dolphin, no files / music on the shuffle is found, and none can be loaded.

How to reproduce
-----
1. iPod shuffle. It has 1.7 gig/2.0 gig used previously loaded from previous install of Rhythmbox from Fedora 13 install
2. Installed Fedora 14 (fresh) live. Installed latest Rhythmbox in repositories.
3. Mount iPod shuffle, note shuffle is detected but no music is seen (It's there, it plays fine)
4. Sync music - crashes Rhythmbox

Comment 1 Joe Buckley 2010-12-11 01:52:36 UTC
Created attachment 468100 [details]
File: backtrace

Comment 2 Joe Buckley 2010-12-12 03:03:50 UTC
Package: rhythmbox-0.13.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Using sync mechanism, loaded 1.7 gigs of music onto iPod Shuffle from Rhythmbox
2. Unmount iPod Shuffle
3. Remount iPod Shuffle. From Rhythmbox, note the iPod is detected, but not the loaded music/playlists from last sync
4. Rightclick on iPod icon and select "properties". Rhythmbox crashes.


Comment
-----
See reproduction of crash section.

Comment 3 abrt-bot 2012-03-21 16:50:29 UTC
Backtrace analysis found this bug to be similar to bug #701746, closing as duplicate.

Bugs which were found to be similar to this bug: bug #655198, bug #673245, bug #679724, bug #701746

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 701746 ***


Note You need to log in before you can comment on or make changes to this bug.