Bug 662298 - [abrt] crash in exaile-0.3.2.0-2.fc14
Summary: [abrt] crash in exaile-0.3.2.0-2.fc14
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: exaile
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:08997608
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-11 10:48 UTC by Raphael Groner
Modified: 2011-03-28 19:33 UTC (History)
12 users (show)

Fixed In Version: exaile-0.3.2.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of: 561029
Environment:
Last Closed: 2011-03-04 17:19:09 UTC


Attachments (Terms of Use)
Crash report (2.47 KB, text/plain)
2010-12-11 10:48 UTC, Raphael Groner
no flags Details

Description Raphael Groner 2010-12-11 10:48:59 UTC
Created attachment 468135 [details]
Crash report

Abrt detected this as a closed bug. But it happens also in Fedora 14.

exaile-0.3.2.0-2.fc14.noarch



+++ This bug was initially created as a clone of Bug #561029 +++

abrt 1.0.4 detected a crash.

architecture: i686
cmdline: python /usr/lib/python2.6/site-packages/exaile/exaile.py --datadir=/usr/share/exaile/data --startgui -q
component: exaile
executable: /usr/lib/python2.6/site-packages/exaile/exaile.py
kernel: 2.6.31.12-174.2.3.fc12.i686.PAE
package: exaile-0.3.0.1-1.fc12
release: Fedora release 12 (Constantine)

backtrace
-----
Summary: TB08997608 connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.764 was not provided by any .service files

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/exaile/exaile.py", line 56, in <module>
    main()
  File "/usr/lib/python2.6/site-packages/exaile/exaile.py", line 53, in main
    exaile = main.Exaile()
  File "/usr/lib/python2.6/site-packages/exaile/xl/main.py", line 85, in __init__
    if xldbus.check_exit(self.options, self.args):
  File "/usr/lib/python2.6/site-packages/exaile/xl/xldbus.py", line 54, in check_exit
    iface.TestService('testing dbus service')
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.764 was not provided by any .service files

Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SessionBus (session) at 0x9c816bc>
args: ('testing dbus service',)
utf8_strings: False
bus_name: dbus.UTF8String(':1.764')
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: '/org/exaile/Exaile'
timeout: -1.0
signature: None
dbus_interface: 'org.exaile.Exaile'
message: <dbus.lowlevel.MethodCallMessage object at 0x9c136f0>
method: 'TestService'

--- Additional comment from tncarrolls@msn.com on 2010-02-02 15:33:42 CET ---

Created attachment 388311 [details]
File: backtrace

--- Additional comment from updates@fedoraproject.org on 2010-02-10 17:18:53 CET ---

exaile-0.3.0.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/exaile-0.3.0.2-1.fc12

--- Additional comment from updates@fedoraproject.org on 2010-02-11 15:33:30 CET ---

exaile-0.3.0.2-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update exaile'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1693

--- Additional comment from updates@fedoraproject.org on 2010-02-20 01:31:45 CET ---

exaile-0.3.0.2-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from nomnex@gmail.com on 2010-08-11 09:43:33 CEST ---

exaile-0.3.0.2-1.fc12 here on Fedora 13.

Python26 persistent crash with Exaile (ABRT tool reported a bug duplicate with this bug ref.)

How to reproduce the crash.

1. Exaile is playing an audio file (tested with .mp3)
2. Right click another audio file in nautilus and select "open with" Exaile
3. Crash occurs + ABRT pops up with a Python2.6 lib crash.

Can you re-open this bug or do I create another bug report manually? Thanks

--- Additional comment from raphgro@web.de on 2010-08-23 20:20:42 CEST ---

(In reply to comment #5)
I can confirm a bug with Fedora 13. ABRT found this closed bug as a duplicate.

Package:    	exaile-0.3.2.0-1.fc13
Latest Crash:	Mo 23 Aug 2010 20:09:55 
Command:    	python /usr/lib/python2.6/site-packages/exaile/exaile.py --datadir=/usr/share/exaile/data --startgui '04-Danny Noise - Lucky Star (X-Mas House Edit).mp3'
Reason:     	connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
Comment:    	Miro can play the file.
Bug Reports:	Status: CLOSED ERRATA
		https://bugzilla.redhat.com/show_bug.cgi?id=561029

connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.6/site-packages/exaile/xl/xldbus.py", line 453, in Enqueue
    tracks = trax.sort_tracks(['album', column], tracks, descending)
  File "/usr/lib/python2.6/site-packages/exaile/xl/trax/util.py", line 90, in sort_tracks
    return sorted(iter, key=keyfunc, reverse=reverse)
  File "/usr/lib/python2.6/site-packages/exaile/xl/trax/util.py", line 89, in <lambda>
    artist_compilations=artist_compilations) for field in fields]
TypeError: 'bool' object is not callable


Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/exaile/exaile.py", line 52, in <module>
    main()
  File "/usr/lib/python2.6/site-packages/exaile/exaile.py", line 49, in main
    exaile = main.Exaile()
  File "/usr/lib/python2.6/site-packages/exaile/xl/main.py", line 83, in __init__
    exit = xldbus.check_exit(self.options, self.args)
  File "/usr/lib/python2.6/site-packages/exaile/xl/xldbus.py", line 78, in check_exit
    iface.Enqueue(args)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.6/site-packages/exaile/xl/xldbus.py", line 453, in Enqueue
    tracks = trax.sort_tracks(['album', column], tracks, descending)
  File "/usr/lib/python2.6/site-packages/exaile/xl/trax/util.py", line 90, in sort_tracks
    return sorted(iter, key=keyfunc, reverse=reverse)
  File "/usr/lib/python2.6/site-packages/exaile/xl/trax/util.py", line 89, in <lambda>
    artist_compilations=artist_compilations) for field in fields]
TypeError: 'bool' object is not callable


Local variables in innermost frame:
byte_arrays: False
self: <dbus._dbus.SessionBus (session) at 0xee58f0>
args: (['/tmp/xa-9lYV4s/04-Danny Noise - Lucky Star (X-Mas House Edit).mp3'],)
utf8_strings: False
bus_name: dbus.UTF8String(':1.57')
get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
object_path: '/org/exaile/Exaile'
timeout: -1.0
signature: u'as'
dbus_interface: 'org.exaile.Exaile'
message: <dbus.lowlevel.MethodCallMessage object at 0xecf480>
method: 'Enqueue'

Comment 1 Richard Merlier 2010-12-14 07:58:06 UTC
Package: exaile-0.3.2.0-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Set exaile as default music application for .mp3
2.Open an music file .mp3 from nautilus
3.


Comment
-----
I just wanted to open a song in exaile, from nautilus.

Comment 2 Richard Merlier 2010-12-14 08:19:58 UTC
I just forgot to say the bug appears only when exile is already running.

Comment 3 Raphael Groner 2010-12-14 09:41:09 UTC
Richard,
look into the Crash report. The issue is related to D-Bus.

DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Maybe then only a wrong configuration thingy? But dunno how to fix.

Comment 4 christian 2010-12-20 06:28:29 UTC
Package: exaile-0.3.2.0-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.play music
2.
3.

Comment 5 endika-paino-paya 2010-12-29 04:15:02 UTC
Package: exaile-0.3.2.0-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Escuchando una cancion, y poniendo otra a la vez desde nautilus.
2.
3.

Comment 6 gluengo 2010-12-31 01:30:36 UTC
Package: exaile-0.3.2.0-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.reproduci mp3 temporal desde una pagina
2.
3.

Comment 7 Gajdos Tamás 2011-01-03 18:38:02 UTC
Package: exaile-0.3.2.0-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Just clicked the program to start.
2. In the background, ran a yum:
yum install gstreamer-plugins-bad gstreamer-plugins-bad-free-extras gstreamer-plugins-bad-nonfree gstreamer-plugins-ugly

Comment 8 Nobuhide 2011-02-06 01:58:00 UTC
Package: exaile-0.3.2.0-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.終了時にクラッシュ
2.
3.

Comment 9 Fedora Update System 2011-03-04 15:41:06 UTC
Package exaile-0.3.2.1-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing exaile-0.3.2.1-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/exaile-0.3.2.1-1.fc14
then log in and leave karma (feedback).

Comment 10 Raphael Groner 2011-03-04 17:19:09 UTC
In the meanwhile, I am using Fedora 14 without Exaile. So I am not able to reproduce and closing this bug.

Comment 11 Fedora Update System 2011-03-28 19:31:07 UTC
exaile-0.3.2.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.