Bug 6623 - /sbin/install-info sometimes silently fails to do anything
Summary: /sbin/install-info sometimes silently fails to do anything
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: texinfo (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-02 00:13 UTC by Chris Siebenmann
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-15 22:08:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Siebenmann 1999-11-02 00:13:42 UTC
It appears that the --entry=... option of install-info
may be broken; I noticed this because several RPM packages
that use /sbin/install-info ... --entry="..." failed to
actually install info entries into the info directory.

 Examples are cvs and bison.

Comment 1 Cristian Gafton 2000-02-05 05:13:59 UTC
*** This bug has been marked as a duplicate of 5639 ***

Comment 2 Chris Siebenmann 2000-02-05 05:35:59 UTC
I don't think that this should be considered a duplicate of
5639, since resolving 5639 (by, for example, changing the CVS
RPM to not use '--entry=...') does nothing to actually make
--entry=... actually *work*. Which is what this bug report
is about.

 Fixing the symptoms in Redhat-packaged RPMs still leaves the
program buggy and any third party programs, packages, Makefiles,
etc that are relying on the documented functionality up a creek.

(Of course, Redhat may consider this an issue for the FSF to fix
and not something they can or want to patch in the mean time, in
which case close this bug again -- but please reassure us that
you're doing it for that reason.)

Comment 3 Cristian Gafton 2000-02-15 22:08:59 UTC
All the test cases I threw at it work correctly here. A test case would be much
appreciated. Please reporn if you find one

Comment 4 Chris Siebenmann 2000-02-15 22:21:59 UTC
The following test case is ripped off from 'rpm -q --scripts bison':
	grep -v bison /usr/info/dir >/tmp/dir
	/sbin/install-info /usr/info/bison.info.gz /tmp/dir --entry="* bison:
(bison).                        The GNU parser generator."
	grep bison /tmp/dir
(and observe that, verily, /sbin/install-info will not have added
anything, because the grep will produce no output.)

 A similar test-case can be gotten from the RedHat 6.1 'rpm -q
--scripts cvs'.


Note You need to log in before you can comment on or make changes to this bug.