Bug 66231 - "perl -v" no longer works in pipes
"perl -v" no longer works in pipes
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: perl (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-06 12:04 EDT by ellson
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-11 15:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ellson 2002-06-06 12:04:30 EDT
Description of Problem:
The behavior of "perl -v" has changed (in last night's rawhide update)
Before perl-5.8.0-16 it was possible to test the version of
perl with:  perl -v | fgrep 'v5.'
Now, with perl-5.8.0-16 the output of "perl -v" is no longer
accessible via a pipe.

Version-Release number of selected component (if applicable):
perl-5.8.0-16


How Reproducible:
100%


Steps to Reproduce:
1. perl -v | cat   
2. 
3. 

Actual Results:
produces no output


Expected Results:
same output as "perl -v"


Additional Information:
Multiple gnome2 configure scripts are failing because of this.
Including:  intltool and bonobo-activation
Comment 1 Chip Turner 2002-06-11 15:47:30 EDT
I believe this is fixed now.
Comment 2 ellson 2002-06-11 15:54:27 EDT
Yes, verified fixed in perl-5.8.0-19. Thx.

Note You need to log in before you can comment on or make changes to this bug.