Bug 662484 - nfs-utils changes make rpcidmapd service to fail
nfs-utils changes make rpcidmapd service to fail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-12 16:48 EST by Michal Jaegermann
Modified: 2011-01-05 15:08 EST (History)
3 users (show)

See Also:
Fixed In Version: libnfsidmap-0.24-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-05 15:08:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2010-12-12 16:48:40 EST
Description of problem:

On the current rawhide an attempt to run

  service rpcidmapd start

results in the following:

Starting rpcidmapd (via systemctl):  Job failed. See system logs and 'systemctl status' for details.
                                                           [FAILED]

System logs do not say much more beyond "Unit rpcidmapd.service entered failed state." and trying to follow advice about 'systemctl status' brings up only "Too few arguments." in a response. 'service rpcidmapd status' repeats the above in a more wordy manner.  Not that enlightning.

Actually boot messages give somewhat more:

Starting Permit User Sessions...
rpc.idmapd: libnfsidmap: requested translation method, 'nsswitch', is not available

rpc.idmapd: Unable to create name to user id mappings.

Only now something broke logging that in /var/log/boot.log and this is hard to find.  Any idea what is responsible for that bogosity?

Besides nothings seems to be wrong with /lib64/libnfsidmap/nsswitch.so library.

Version-Release number of selected component (if applicable):
nfs-utils-1.2.3-5.fc15.x86_64
libnfsidmap-0.24-2.fc15.x86_64

How reproducible:
always
Comment 1 Jason Tibbitts 2010-12-15 21:28:43 EST
I'm seeing this as well.  /var/log/messages has:

Dec 15 18:53:34 v02 rpc.idmapd[1109]: libnfsidmap: using (default) domain: math.uh.edu
Dec 15 18:53:34 v02 rpc.idmapd[1109]: libnfsidmap: Unable to load plugin: /usr/lib64/libnfsidmap/nsswitch.so: cannot open shared object file: No such file or directory
Dec 15 18:53:34 v02 rpc.idmapd[1109]: libnfsidmap: requested translation method, 'nsswitch', is not available
Dec 15 18:53:35 v02 systemd[1]: rpcidmapd.service: control process exited, code=exited status=1
Dec 15 18:53:35 v02 systemd[1]: Unit rpcidmapd.service entered failed state.

/usr/lib64/libnfsidmap is empty, but /lib64/libnfsidmap exists and has the proper stuff in it.  I made a symlink and restarted and the daemon starts.

nfs-utils-1.2.3-6.fc15.x86_64
libnfsidmap-0.24-2.fc15.x86_64
Comment 2 Steve Dickson 2011-01-05 15:08:33 EST
This is fixed with the latest version of libnfsidmap-0.24-3.fc15

Note You need to log in before you can comment on or make changes to this bug.