Bug 66261 - gdk-pixbuf should dither images in 16bpp
gdk-pixbuf should dither images in 16bpp
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gtk2 (Show other bugs)
7.3
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-06 16:43 EDT by Garrett LeSage
Modified: 2007-03-26 23:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 14:10:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garrett LeSage 2002-06-06 16:43:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
gdk-pixbuf currently does not dither images in 16bpp; visible banding occurs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. View images used in GTK+ widgets.
2. Horrible banding occurs on gradients and alpha gradients.

Expected Results:  Images displayed using GTK+2, such as those in Anaconda,
up2date, etc. should look fine in 16bpp, with no banding. Dithering would make
things look "normal".

Additional info:
Comment 1 Owen Taylor 2002-10-31 19:13:20 EST
It's not at all clear to me that changing 16bpp to dither at 
GTK_DITHER_NORMAL level would be a compatible change... note
also in many cases the problem is that rendering is going
through the alpha-composited path, which can never be dithered.
Comment 2 Owen Taylor 2003-01-14 18:02:27 EST
Marking various no-need-to-be-private bugs public.
Comment 3 Owen Taylor 2003-01-14 18:03:49 EST
Marking various no-need-to-be-private bugs public.
Comment 4 Matthias Clasen 2004-05-12 14:10:59 EDT
I think Owen is right. The docs for GdkRgbDither clearly define 
that GDK_RGB_DITHER_NORMAL doesn't dither at 16bpp. This must be fixed 
in the caller by using GDK_RGB_DITHER_MAX. I don't know how anaconda
displays its images...

Note You need to log in before you can comment on or make changes to this bug.