Bug 662669 - vg_validate needs to catch broken internal LVs
vg_validate needs to catch broken internal LVs
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Petr Rockai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-13 10:03 EST by Petr Rockai
Modified: 2010-12-14 12:08 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-14 12:08:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Rockai 2010-12-13 10:03:25 EST
This comes from 643538: we need to improve vg_validate to catch the situation arising in that bug, since the resulting metadata is corrupt. Basically, this amounts to checking that pvmove LVs are actually mirrors. In the bug, the pvmove LV becomes an "error" segment.
Comment 1 Petr Rockai 2010-12-13 12:45:30 EST
(It may also make sense to make sure they are 2 way mirrors.)
Comment 2 Petr Rockai 2010-12-14 12:08:50 EST
The code for this has been reviewed and checked upstream. Closing.

Note You need to log in before you can comment on or make changes to this bug.