Bug 66278 - libs6.so has no symbols
libs6.so has no symbols
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-07 00:49 EDT by Need Real Name
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-07 10:59:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-06-07 00:49:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
[root@dm lib]# nm libc-2.2.5.so
nm: libc-2.2.5.so: no symbols


compared with Suse 8.0:

[root@dm lib]# nm libc.so.6 |less

00000000 A GCC_3.0
00000000 A GLIBC_2.0
00000000 A GLIBC_2.1
00000000 A GLIBC_2.1.1
00000000 A GLIBC_2.1.2
00000000 A GLIBC_2.1.3
00000000 A GLIBC_2.2
00000000 A GLIBC_2.2.1
00000000 A GLIBC_2.2.2
00000000 A GLIBC_2.2.3
00000000 A GLIBC_2.2.4
00000000 A GLIBC_2.2.5

This causes SAP GUI to not start:

Cannot load shared library or some dependent library:
java.lang.UnstatisfiedLinkError:
/opt/SAPGUI_for_java/6.20/bin/libJPlatin.so:/opt/SAPGUI......
symbol gethostent_r, version GLIBC_2.1.2 not defined in file libc.so.6
with link reference


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
nm libc6.so

Additional info:
Comment 1 Need Real Name 2002-06-07 01:18:29 EDT
Sorry, I were wrong.
I didn't know that there is /lib/i686
But, anyway, this problem exists with Sun jdk 1.3.1 and 1.4.0.
Using of IBM jdk 1.3.1 solves problem.
But there was no such problem on RH 7.2!
Comment 2 Jakub Jelinek 2002-06-07 10:59:19 EDT
Even /lib/libc.so.6 has the dynamic symbol table (otherwise it would be useless),
see readelf -s /lib/libc.so.6 or nm -D /lib/libc.so.6.
The fact is that because of a bug get*ent_r@@GLIBC_2.1.2 functions are not
exported (but e.g. get*ent_r@GLIBC_2.0 are).
I've fixed this in:
http://sources.redhat.com/ml/libc-hacker/2002-06/msg00008.html
Will work on a 7.3 errata for this next week.
Comment 3 Jakub Jelinek 2002-07-11 05:43:27 EDT
This was fixed in glibc-2.2.5-36.

Note You need to log in before you can comment on or make changes to this bug.