Bug 662797 - move harness files from under /tmp to /mnt/testarea
Summary: move harness files from under /tmp to /mnt/testarea
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: beah
Version: 0.5
Hardware: All
OS: Linux
high
high vote
Target Milestone: 0.10.0
Assignee: Dan Callaghan
QA Contact: Qixiang Wan
URL:
Whiteboard: Misc
: 653857 668763 878411 (view as bug list)
Depends On:
Blocks: 593663 625782 653857 667986 668757 668763
TreeView+ depends on / blocked
 
Reported: 2010-12-13 21:53 UTC by Marian Csontos
Modified: 2012-11-23 03:25 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-22 06:43:41 UTC


Attachments (Terms of Use)

Description Marian Csontos 2010-12-13 21:53:22 UTC
- the /tmp may not persist the reboot/test
- root should not write to /tmp (or at least I was told selinux does not like that)
- some tests require limited space on /tmp partition

Comment 1 Jan Stancek 2012-10-03 08:17:24 UTC
This is starting to be an issue with recent RHEL7 nightly trees, because /tmp is mounted as tmpfs and it goes away after each reboot:
Bug 810515 - tmpfs as default filesystem on /tmp

For example when kernelinstall makes reboot task aborts with:
Upon execvpe /tmp/tmpnhFd4I.sh ['/tmp/tmpnhFd4I.sh', 'distribution-distribution-kernelinstall'] in environment id 43387024
:Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/twisted/internet/process.py", line 414, in _fork
    executable, args, environment)
  File "/usr/lib64/python2.7/site-packages/twisted/internet/process.py", line 460, in _execChild
    os.execvpe(executable, args, environment)
  File "/usr/lib64/python2.7/os.py", line 353, in execvpe
    _execvpe(file, args, env)
  File "/usr/lib64/python2.7/os.py", line 368, in _execvpe
    func(file, *argrest)
OSError: [Errno 2] No such file or directory

Comment 2 Jeff Burke 2012-10-03 12:26:02 UTC
Minjung,
 I have bumped the Severity and the Priority of this BZ. This is becoming a blocking issue. Can we take this BZ of of future_maint?

Thanks,
Jeff

Comment 3 Bill Peck 2012-10-03 22:10:24 UTC
http://gerrit.beaker-project.org/#/c/1403/

Comment 4 Min Shin 2012-10-04 05:39:38 UTC
Jeff, I proposed this to be in Beaker 0.10 which is currently scheduled to be released in week 47. Is this enough for your need?

Comment 5 Dan Callaghan 2012-10-10 05:23:10 UTC
*** Bug 668763 has been marked as a duplicate of this bug. ***

Comment 6 Nick Coghlan 2012-10-17 04:38:56 UTC
Bulk reassignment of issues as Bill has moved to another team.

Comment 8 Dan Callaghan 2012-10-26 04:00:16 UTC
*** Bug 653857 has been marked as a duplicate of this bug. ***

Comment 9 Qixiang Wan 2012-11-09 06:39:59 UTC
Verified by provision a system and checking the harness files on system after installation. Now the harness files are placed in /mnt/testarea rather /tmp.

Comment 10 Qixiang Wan 2012-11-15 05:05:16 UTC
/distribution/kernelinstall task also passed with beaker-0.9.4-2.git.104.1433411.el6 + beah-0.6.41-1.el6eng (which contains the fix for this bug).

Comment 11 Petr Sklenar 2012-11-21 08:35:08 UTC
(In reply to comment #10)
> /distribution/kernelinstall task also passed with
> beaker-0.9.4-2.git.104.1433411.el6 + beah-0.6.41-1.el6eng (which contains
> the fix for this bug).

Could you verify it by trying rhts-reboot / normal reboot is working as we could see in bug 878411?

Comment 12 Petr Sklenar 2012-11-21 08:36:53 UTC
*** Bug 878411 has been marked as a duplicate of this bug. ***

Comment 13 Qixiang Wan 2012-11-21 09:06:06 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > /distribution/kernelinstall task also passed with
> > beaker-0.9.4-2.git.104.1433411.el6 + beah-0.6.41-1.el6eng (which contains
> > the fix for this bug).
> 
> Could you verify it by trying rhts-reboot / normal reboot is working as we
> could see in bug 878411?

Unfortunately, RHEL7 is not working well on my beaker instance, so I can't check this now.

I tried /distribution/kernelinstall task with RHEL6 (comment 10), this task has rhts-reboot action include during the test, and it works. We can double check this with RHEL7 once the new build is deployed.

Comment 14 John Brier 2012-11-21 14:41:39 UTC
I realize this is already VERIFIED, but I wanted to throw something in the discussion on this. Why are any test files under /mnt? As a new user of beaker one of the first things that is confusing is noticing that nothing is actually mounted under /mnt for the tests. Why not put them somewhere else that doesn't imply a remote FS?

Comment 15 Raymond Mancy 2012-11-22 06:43:41 UTC
This has now been released

Comment 16 Amit Saha 2012-11-23 03:25:30 UTC
(In reply to comment #14)
> I realize this is already VERIFIED, but I wanted to throw something in the
> discussion on this. Why are any test files under /mnt? As a new user of
> beaker one of the first things that is confusing is noticing that nothing is
> actually mounted under /mnt for the tests. Why not put them somewhere else
> that doesn't imply a remote FS?

This is just my *guess*, but it could be the legacy of rhts (http://git.beaker-project.org/cgit/rhts/).


Note You need to log in before you can comment on or make changes to this bug.