Bug 66281 - mount version after 2.11b falis to mount smbfs partition
mount version after 2.11b falis to mount smbfs partition
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-07 01:55 EDT by pogosyan
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-20 15:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pogosyan 2002-06-07 01:55:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-3 i686)

Description of problem:
After upgrading mount from 2.11b (RH 7.1) to later versions (tried - 2.11g from
7.2,  2.11n from 7.3, 2.11n-15 from Rawhide), attempt to mount Samba partion via
autofs, as well as with 'mount -t smbfs' fails.

smbmount called directly works all right,  backing down to mount 2.11b (keeping
all other upgrades I made to move, partially, from RH7.1 to 7.3) restores mount
functionality.

Version-Release number of selected component (if applicable):
mount > 2.11b

How reproducible:
Always

Steps to Reproduce:
Setup: RH 7.1 with kernel and glibc (+ dependences) upgraded to RH7.3
mount-2.11n.  Samba-2.2.4 (rpm from samba site) serves share C on windows
machine
called ladybug.  Samba mount point /misc is NOT mentioned in fstab

1.   Run smbmount  
# smbmount  //ladybug/C /misc
Password: xxxxxxxx
# mount
.....
//ladybug/C on /misc type smbfs
#

2.  unmount  
# umount   //ladybug/C
3.  Attempt mounting with mount fails
# mount -V
mount: mount-2.11n
# mount -t smbfs //ladybug/C  /misc
Password: xxxxxxx
execvp of smbmnt failed. Error was No such file or directory.smbmnt failed: 1

4.  Restore old RH7.1 mount package and try again
# rpm -U --oldpackage --nodeps mount-2.11b-3.i386.rpm
# mount -V
mount: mount-2.11b
# mount -t smbfs //ladybug/C  /misc
Password: xxxxxxxxxxx
# mount
//ladybug/C on /misc type smbfs (0)

5.  Check smbmnt for any case
# ls -l /usr/sbin/smbmnt
-rwxr-xr-x    1 root     root       453868 May  5 14:01 /usr/sbin/smbmnt

Actual Results:  I expected old mount functionality to work as in previous
version with smbfs system.


Additional info: 
In reality I had autofs setup which suddently stopped working after upgrade.
/var/log/messages contained mount errors, same as I was able to reproduce with
direct calling to mount -t smbfs above.
Comment 1 Elliot Lee 2002-06-20 12:47:45 EDT
It works here with rawhide as long as I have the samba-client package installed.
Comment 2 pogosyan 2002-06-20 12:54:47 EDT
I have samba RPM from samba website, not RedHat. It includes in one package what
RH has in split packages.

Samba has released recently the version 2.2.5. I'll try this, and also will try
RH rawhide Samba packages and report then.
Comment 3 pogosyan 2002-06-20 13:42:12 EDT
samba 2.2.5 from samba site still conflicts with mount-11n,
however you are right, mount-2.11n-5  with samba packages from rawhide (2.2.4)
does work.

Unfortunately, rawhide samba packages require (why ???) libcups.
I don't use cups printing and prefer not to have useless packages
installed.  I do not understand why samba would require any particular
printing package ( or any printing packages whatsover).
Comment 4 Elliot Lee 2002-06-20 14:23:12 EDT
samba decides to link all its binaries against libraries that any of its binaries need...
I'll assign to the samba package for fixing.
Comment 5 pogosyan 2002-06-20 15:11:01 EDT
OK, the problem is understood
the difference in samba packages from samba site and rawhide
is that former has smbmount and smbmnt executables in /usr/sbin and latter - in
/usr/bin.   Somehow recent mount cannot find needed
things in /usr/sbin (Im told it is smbmount which looks for smbmnt in BINDIR,
rather than SBINDIR, bout mount may affect set pathes).
Comment 6 Trond Eivind Glomsrxd 2002-07-23 22:03:11 EDT
Mount and samba cooperates as distributed.
Comment 7 Andrew Bartlett 2002-09-01 07:10:16 EDT
I'm working with the debian folk on getting the dependencies down, but we tried
once and compeatly broke stuff.  The second attempt is in HEAD at the moment,
and will be expanded slowly.  Don't expect this in 2.2 however.

Note You need to log in before you can comment on or make changes to this bug.