Bug 662907 - Publican reformats <address> when it cleans XML
Publican reformats <address> when it cleans XML
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.5
All Linux
low Severity low
: ---
: ---
Assigned To: Ruediger Landmann
Ruediger Landmann
:
: 671291 (view as bug list)
Depends On:
Blocks: 671291
  Show dependency treegraph
 
Reported: 2010-12-14 01:30 EST by Ruediger Landmann
Modified: 2013-07-29 21:31 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 642902
: 671291 (view as bug list)
Environment:
Last Closed: 2011-07-25 20:42:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Ruediger Landmann 2011-01-20 21:22:47 EST
XmlClean wasn't treating <address> as verbatim content and was inserting newlines after <street>, <country>, <phone>, and <fax>. Whitespace is honoured in <address> anyway[0] and somehow the end result was a leading non-breaking space on every line of the address after the first.

Fixed in commit 1704


[0] http://www.docbook.org/tdg/en/html/address.html
Comment 2 Jeff Fearn 2011-07-01 07:16:53 EDT
Back ported to branches/publican-2x

Committed revision 1796.
Comment 3 Rebecca Newton 2011-07-12 20:48:29 EDT
I can verify that this fix is working as expected.
Comment 4 Ruediger Landmann 2013-07-29 21:31:27 EDT
*** Bug 671291 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.