Bug 662978 - JON241: RHQ-Agent log exception - java.lang.NoSuchMethodException: org.rhq.plugins.jbossas.JBossASServerComponent.getConnection()
JON241: RHQ-Agent log exception - java.lang.NoSuchMethodException: org.rhq.pl...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
3.0.0
Unspecified Unspecified
low Severity medium (vote)
: ---
: ---
Assigned To: Lukas Krejci
Corey Welton
:
Depends On:
Blocks: 725852 jon241-bugs
  Show dependency treegraph
 
Reported: 2010-12-14 05:15 EST by Rajan Timaniya
Modified: 2011-07-28 12:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-23 21:09:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
agent log (256.24 KB, application/octet-stream)
2010-12-14 05:15 EST, Rajan Timaniya
no flags Details

  None (edit)
Description Rajan Timaniya 2010-12-14 05:15:23 EST
Created attachment 468573 [details]
agent log

Description of problem:
RHQ-Agent log exception - 

2010-12-14 15:17:15,842 WARN  [InventoryManager.discovery-1] (rhq.core.pc.inventory.InventoryManager)- Failure during discovery for [JMS Manager] Resources - failed after 0 ms.
java.lang.Exception: Discovery component invocation failed.
	at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ComponentInvocationThread.call(DiscoveryComponentProxyFactory.java:283)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:619)
Caused by: java.lang.NoSuchMethodException: org.rhq.plugins.jbossas.JBossASServerComponent.getConnection()
	at java.lang.Class.getMethod(Class.java:1605)
	at org.jboss.as.integration.hornetq.jopr.JMSManagerDiscoveryComponent.getProfileService(JMSManagerDiscoveryComponent.java:65)
	at org.jboss.as.integration.hornetq.jopr.JMSManagerDiscoveryComponent.discoverResources(JMSManagerDiscoveryComponent.java:44)
	at sun.reflect.GeneratedMethodAccessor75.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.rhq.core.pc.util.DiscoveryComponentProxyFactory$ComponentInvocationThread.call(DiscoveryComponentProxyFactory.java:279)
	... 5 more
2010-12-14 15:17:16,379 INFO  [ResourceDiscoveryComponent.invoker.daemon-1] (org.rhq.plugins.postgres.PostgresTableDiscoveryComponent)- Discovering postgres users

Version-Release number of selected component (if applicable):
JON 2.4.1 build #41 (build number: 10963:e46b3e2)

How reproducible:
Always

Steps to Reproduce:
1. Install rhq-server and rhq-agent where JBossAS5 server is running. Ensure
that jboss-as-5 plugin is present.
2. Import the auto discovered JBossAS5 server.
3. Uninventory the JBossAS5 server.
4. Restart both rhq server and agent and JBossAS5 server.
5. Observe agent.log
  
Actual results:
RHQ-Agent log exception - java.lang.NoSuchMethodException: org.rhq.plugins.jbossas.JBossASServerComponent.getConnection()

Expected results:
RHQ-Agent log should not give NoSuchMethodException.

Additional info:
Please refer attached agent.log
Comment 1 Lukas Krejci 2010-12-15 13:03:16 EST
Could not reproduce with RHQ 3.0.1-SNAPSHOT commit 0a53ca30d70fe38283185673bff7aeae58ea33d5.

Could you please re-test this with the next JON build?
Comment 3 Rajan Timaniya 2010-12-16 04:25:41 EST
Verified on JON-2.4.1 build #42 (build number: 10963:0a53ca3)

Now, there isn't NoSuchMethodException in RHQ-Agent log.
Comment 4 Corey Welton 2011-05-23 21:09:54 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.