Bug 66300 - afpd looks for nls files in a bad directory path
afpd looks for nls files in a bad directory path
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: netatalk (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-07 06:00 EDT by Alain RICHARD
Modified: 2015-03-04 20:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-07 06:00:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alain RICHARD 2002-06-07 06:00:01 EDT
From Bugzilla Helper:



User-Agent: Mozilla/4.0 (compatible; MSIE 5.14; Mac_PowerPC)







Description of problem:



When you use a codepage:maccode.iso8859-1 option in 

/etc/atalk/AppleVolumes.default, the afpd process fail to load the 

translation table maccode.iso8859-1 because it looks to it in the directory







/usr/etc/netatalk/nls







instead of looking for it where it is really installed :







/etc/atalk/nls











Version-Release number of selected component (if applicable):











How reproducible:



Always







Steps to Reproduce:



1.specify a codepage:maccode.iso8859-1 in 

/etc/atalk/AppleVolumes.default



2.start netatalk



3.try to connect to the shared folder from a Mac and look at 

/var/log/message for the error







	







Actual Results:  the translation table is not loaded, so european diatrical 

marks are not in sync between MacOS/Linux/Samba.



The filename stored on the share are using the MacOS charset and 

unusable from the Linux or Samba side.







Expected Results:  The filename should be translated to ISO-1 charset in 

order to be shared with the other plateforms







Additional info:







A temporary fix  :







mkdir -p /usr/etc/netatalk



cd /usr/etc/netatalk



ln -s ../../../etc/atalk/nls nls
Comment 1 Phil Knirsch 2002-06-18 08:17:51 EDT
Fixed in latest rawhide build. Also updated to latest version 1.5.3.1 on sf.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.