Bug 663014 - [abrt] bluefish-2.0.2-4.fc14: __strlen_sse2_bsf: Process /usr/bin/bluefish was killed by signal 11 (SIGSEGV)
Summary: [abrt] bluefish-2.0.2-4.fc14: __strlen_sse2_bsf: Process /usr/bin/bluefish wa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bluefish
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:47360d74066e735283a5788ccf5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-14 12:56 UTC by Davor
Modified: 2010-12-25 03:39 UTC (History)
2 users (show)

Fixed In Version: bluefish-2.0.2-5.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-25 00:30:18 UTC


Attachments (Terms of Use)
File: backtrace (25.28 KB, text/plain)
2010-12-14 12:56 UTC, Davor
no flags Details
patch (1.31 KB, patch)
2010-12-15 03:41 UTC, Jim Hayward
no flags Details | Diff
Revised patch (1.83 KB, patch)
2010-12-18 15:36 UTC, Jim Hayward
no flags Details | Diff

Description Davor 2010-12-14 12:56:47 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: bluefish /home/davor/Web/Papak/galerija.html /home/davor/Web/Papak/galerija2.html /home/davor/Web/Papak/galerija3.html /home/davor/Web/Papak/index.html /home/davor/Web/Papak/kontakt.html /home/davor/Web/Papak/lm.js /home/davor/Web/Papak/omeni.html /home/davor/Web/Papak/pp.js /home/davor/Web/Papak/predlozak.html /home/davor/Web/Papak/slika.html /home/davor/Web/Papak/style.css
comment: I have no problem. Replacement was finished well. But Bugzilla wish to report this.
component: bluefish
crash_function: __strlen_sse2_bsf
executable: /usr/bin/bluefish
kernel: 2.6.35.9-64.fc14.i686
package: bluefish-2.0.2-4.fc14
rating: 4
reason: Process /usr/bin/bluefish was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1292330025
uid: 500

How to reproduce
-----
1.replace string in multiple files
2.
3.

Comment 1 Davor 2010-12-14 12:56:53 UTC
Created attachment 468606 [details]
File: backtrace

Comment 2 Jim Hayward 2010-12-15 03:41:48 UTC
Created attachment 468758 [details]
patch

Fixed upstream SVN revision 6201. Fix will be part of the 2.0.3 release. Patch to fix the Fedora package is attached.

Comment 3 Fedora Update System 2010-12-15 19:01:25 UTC
bluefish-2.0.2-5.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/bluefish-2.0.2-5.fc13

Comment 4 Fedora Update System 2010-12-15 19:01:34 UTC
bluefish-2.0.2-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bluefish-2.0.2-5.fc14

Comment 5 Fedora Update System 2010-12-17 08:20:03 UTC
bluefish-2.0.2-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bluefish'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/bluefish-2.0.2-5.fc13

Comment 6 Jim Hayward 2010-12-18 15:36:34 UTC
Created attachment 469521 [details]
Revised patch

Revised patch to fix another potential issue that was discovered.

Comment 7 Paul Howarth 2010-12-19 11:14:43 UTC
Whilst testing this update, I came across an unrelated, repeatable segfault.

1. Open a large XML file, such as the uncompressed version of http://download.fedora.redhat.com/pub/epel/beta/6/x86_64/repodata/51d199dde1508f8d58483c613d551c93f245ac13402cab26ad754700c09f9d9b-primary.xml.gz

2. Whilst the scanning runs are still in progress, click the "Save As..." button and save the file with a different name. The segfault happens very quickly afterwards.

Comment 8 Jim Hayward 2010-12-19 15:12:30 UTC
I cannot reproduce the segfault with current SVN. This may have been fixed already. A document save bug was fixed in SVN after the release of 2.0.2. I'll have to test with 2.0.2.

The scanning engine goes into a continuous loop and highlighting never completes. This is an unreported bug.

Comment 9 Paul Howarth 2010-12-22 15:27:31 UTC
I can confirm that the segfault is fixed in current svn; is there any forecast for when 2.0.3 will be released? If it's likely to be in the next few weeks then it's probably not worth issuing another update for 2.0.2 with the latest patch.

Comment 10 Fedora Update System 2010-12-25 00:30:13 UTC
bluefish-2.0.2-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-12-25 00:30:31 UTC
bluefish-2.0.2-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Jim Hayward 2010-12-25 03:39:33 UTC
(In reply to comment #9)
> I can confirm that the segfault is fixed in current svn; is there any forecast
> for when 2.0.3 will be released? 

I expect a 2.0.3-rc1 to be released any day now.


Note You need to log in before you can comment on or make changes to this bug.