Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 663016 - syntax error in /usr/share/selinux/devel/include/apps/thunderbird.if
Summary: syntax error in /usr/share/selinux/devel/include/apps/thunderbird.if
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy
Version: 5.6
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-14 13:00 UTC by Milos Malik
Modified: 2013-02-05 13:04 UTC (History)
1 user (show)

Fixed In Version: selinux-policy-2.4.6-306.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-21 09:21:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1069 0 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2011-07-21 09:18:27 UTC

Description Milos Malik 2010-12-14 13:00:45 UTC
Description of problem:
Found by /CoreOS/policycoreutils/Regression/bz588280-sepolgen-ifgen-traceback

Version-Release number of selected component (if applicable):
selinux-policy-devel-2.4.6-300.el5

How reproducible:
always

Steps to Reproduce:
# sepolgen-ifgen -i /usr/share/selinux/devel/include/apps/thunderbird.if
Syntax error on line 1 ` [type=TICK]
# echo $?
0
# sepolgen-ifgen -v -i /usr/share/selinux/devel/include/apps/thunderbird.if
Parsing support macros (/usr/share/selinux/devel/include/support/obj_perm_sets.spt): done.

Parsing interface files:
%--10---20---30---40---50---60---70---80---90--100
Syntax error on line 1 ` [type=TICK]
error parsing file /usr/share/selinux/devel/include/apps/thunderbird.if: could not parse text: "Syntax error on line 1 ` [type=TICK]"
failed to parse some headers: /usr/share/selinux/devel/include/apps/thunderbird.if
# echo $?
0

Actual results:


Expected results:

Comment 1 Miroslav Grepl 2010-12-14 13:06:00 UTC
This is a syntax error



--optinal_policy(`
   allow $1_t $2_dbusd_t:dbus send_msg;

++optional_policy(`
   allow $1_t $2_dbusd_t:dbus send_msg;

Comment 2 RHEL Program Management 2011-01-11 20:23:47 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 3 RHEL Program Management 2011-01-12 15:08:57 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 5 Miroslav Grepl 2011-03-01 17:10:45 UTC
Fixed in selinux-policy-2.4.6-301.el5

Comment 8 Milos Malik 2011-05-03 10:16:00 UTC
I see syntax errors when following files are processed:
./include/system/init.if
./include/services/inetd.if

Comment 9 Miroslav Grepl 2011-05-19 15:25:41 UTC
Fixed in selinux-policy-2.4.6-306.el5

Comment 11 errata-xmlrpc 2011-07-21 09:21:29 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1069.html

Comment 12 errata-xmlrpc 2011-07-21 11:50:04 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1069.html


Note You need to log in before you can comment on or make changes to this bug.