Bug 663019 - [abrt] qt-devel-1:4.7.1-5.fc14: intCeil<unsigned int>: Process /usr/bin/designer-qt4 was killed by signal 8 (SIGFPE)
[abrt] qt-devel-1:4.7.1-5.fc14: intCeil<unsigned int>: Process /usr/bin/desig...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
14
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:3a84aeb3ec5848dd45b147acca6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-14 08:13 EST by Christian Ziemski
Modified: 2012-05-31 16:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-31 16:29:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (86.28 KB, text/plain)
2010-12-14 08:14 EST, Christian Ziemski
no flags Details

  None (edit)
Description Christian Ziemski 2010-12-14 08:13:56 EST
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: designer-qt4
component: qt
crash_function: intCeil<unsigned int>
executable: /usr/bin/designer-qt4
kernel: 2.6.35.9-64.fc14.x86_64
package: qt-devel-1:4.7.1-5.fc14
rating: 4
reason: Process /usr/bin/designer-qt4 was killed by signal 8 (SIGFPE)
release: Fedora release 14 (Laughlin)
time: 1292326045
uid: 500

How to reproduce
-----
Every start of designer-qt4 crashes after a couple of seconds (without any gui appearing).

I'm on a completely up-to-date Fedora 14 x86_64.
That box is running on a Vmware ESX server, if that matters.

I tried it with Gnome, Xfce and Fluxbox.
Comment 1 Christian Ziemski 2010-12-14 08:14:08 EST
Created attachment 468608 [details]
File: backtrace
Comment 2 Christian Ziemski 2010-12-16 08:18:01 EST
Additionl infos:

Not only designer-qt4 is crashing that way, k4dirstat crashes as well.

And the problem seems to be dependant of the user. 
Using one user let it crash. Another one freezes.
And root is working fine. Aha!

So I created a completely fresh user. And he doesn't have the crashes.

I'm now investigating the differences between those users.
Until later...
Comment 3 Christian Ziemski 2010-12-17 03:39:07 EST
It's "solved".

The file
 /var/tmp/kdecache-${USER}/icon-cache.kcache
was the culprit.

I renamed it and now designer-qt4 and k4dirstat are starting (quickly and without crashing). The above file got recreated with the same size.
(I'm running Gnome and/or Fluxbox here, KDE desktop isn't installed, only some KDE components required for some software.)

The crashing has happened for several users created some weeks ago on fresh installation of Fedora 14. It didn't crash for yesterdays' newly created users.

So perhaps some recent software update made incompatible changes? I don't know.

If there is any further interest I can give more information about my system.


Christian
Comment 4 Christian Ziemski 2012-05-31 16:29:09 EDT
Since F14 is really old and the installation in question is beeing deleted soon I'm closing this issue now.

Note You need to log in before you can comment on or make changes to this bug.