Bug 663060 - candlepin deploy: Failed to compile: error in opening zip file oauth-provider-20100527.jar
Summary: candlepin deploy: Failed to compile: error in opening zip file oauth-provider...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 0.5
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-12-14 15:19 UTC by John Sefler
Modified: 2015-05-14 15:23 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-14 17:43:58 UTC


Attachments (Terms of Use)

Description John Sefler 2010-12-14 15:19:54 UTC
Description of problem:
error: error reading /root/.m2/repository/net/oauth/core/oauth-provider/20100527/oauth-provider-20100527.jar; error in opening zip file
1 error

Started occurring after commit 3d641dfe86364ae5ceadf35446040ba8e682c008

Steps to Reproduce:
201012140001:37.815 - FINE: ssh root@jsefler-f12-candlepin.usersys.redhat.com cd /root/candlepin; git checkout master; git pull (com.redhat.qe.tools.SSHCommandRunner.run)
201012140001:39.824 - FINE: Stdout: 
Updating e5c15b7..b03cce0
Fast-forward
 client/python/candlepinapi.py                      |  314 --------------------
 client/python/cp_client.py                         |  298 -------------------
 proxy/buildfile                                    |   10 +-
 .../java/net/oauth/signature/CustomSigner.java     |   53 ++++
 .../org/fedoraproject/candlepin/config/Config.java |   38 ++-
 .../candlepin/config/ConfigProperties.java         |   10 +-
 .../candlepin/exceptions/CandlepinException.java   |    2 +-
 .../resteasy/interceptor/AuthInterceptor.java      |   91 ++++---
 .../interceptor/AuthProvider.java}                 |   17 +-
 .../candlepin/resteasy/interceptor/BasicAuth.java  |    4 +-
 .../resteasy/interceptor/ConsumerAuth.java         |   11 +-
 .../candlepin/resteasy/interceptor/OAuth.java      |  254 ++++++++++++++++
 .../resteasy/interceptor/RestEasyOAuthMessage.java |   86 ++++++
 .../candlepin/resteasy/interceptor/SSLAuth.java    |    5 +-
 .../resteasy/interceptor/TrustedConsumerAuth.java  |    4 +-
 .../candlepin/config/ConfigTest.java}              |   28 ++-
 16 files changed, 536 insertions(+), 689 deletions(-)
 delete mode 100755 client/python/candlepinapi.py
 delete mode 100755 client/python/cp_client.py
 create mode 100644 proxy/src/main/java/net/oauth/signature/CustomSigner.java
 copy proxy/src/main/java/org/fedoraproject/candlepin/{config/SSLAuthFilterConfigParser.java => resteasy/interceptor/AuthProvider.java} (63%)
 create mode 100644 proxy/src/main/java/org/fedoraproject/candlepin/resteasy/interceptor/OAuth.java
 create mode 100644 proxy/src/main/java/org/fedoraproject/candlepin/resteasy/interceptor/RestEasyOAuthMessage.java
 rename proxy/src/{main/java/org/fedoraproject/candlepin/config/SSLAuthFilterConfigParser.java => test/java/org/fedoraproject/candlepin/config/ConfigTest.java} (55%)
 (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140001:39.829 - FINE: Stderr: 
Already on 'master'
From git://git.fedorahosted.org/git/candlepin
   e5c15b7..b03cce0  master     -> origin/master
   ff7ee47..3b9e91d  oauth      -> origin/oauth
 (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140001:39.830 - FINE: ExitCode: 0 (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140001:39.831 - INFO: Asserted: 0 is present in the list [0] (com.redhat.qe.auto.testng.Assert.pass)
201012140001:39.832 - INFO: Asserted: Stderr from command 'cd /root/candlepin; git checkout master; git pull' contains matches to regex '(Already on|Switched to branch) 'master'', (com.redhat.qe.auto.testng.Assert.pass)
201012140001:39.832 - FINE: Matches:  (com.redhat.qe.auto.testng.Assert.assertContainsMatch)
201012140001:39.833 - FINE: Already on 'master' (com.redhat.qe.auto.testng.Assert.assertContainsMatch)
201012140001:39.833 - FINE: ssh root@jsefler-f12-candlepin.usersys.redhat.com cd /root/candlepin; git checkout master (com.redhat.qe.tools.SSHCommandRunner.run)
201012140001:39.938 - FINE: Stdout:  (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140001:39.939 - FINE: Stderr: Already on 'master'
 (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140001:39.940 - FINE: ExitCode: 0 (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140001:39.942 - INFO: Asserted: 0 is present in the list [0] (com.redhat.qe.auto.testng.Assert.pass)
201012140001:39.943 - INFO: Asserted: Stderr from command 'cd /root/candlepin; git checkout master' contains matches to regex '(Already on|Switched to branch) 'master'', (com.redhat.qe.auto.testng.Assert.pass)
201012140001:39.944 - FINE: Matches:  (com.redhat.qe.auto.testng.Assert.assertContainsMatch)
201012140001:39.945 - FINE: Already on 'master' (com.redhat.qe.auto.testng.Assert.assertContainsMatch)
201012140001:39.946 - FINE: ssh root@jsefler-f12-candlepin.usersys.redhat.com service postgresql restart (com.redhat.qe.tools.SSHCommandRunner.run)
201012140001:43.571 - FINE: Stdout: 
Stopping postgresql service: [  OK  ]
Starting postgresql service: [  OK  ]
 (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140001:43.572 - FINE: Stderr:  (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140001:43.573 - FINE: ExitCode: 0 (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140001:43.574 - INFO: Asserted: Stdout from command 'service postgresql restart' contains matches to regex 'Starting postgresql service:\s+\[  OK  \]', (com.redhat.qe.auto.testng.Assert.pass)
201012140001:43.575 - FINE: Matches:  (com.redhat.qe.auto.testng.Assert.assertContainsMatch)
201012140001:43.575 - FINE: Starting postgresql service: [  OK  ] (com.redhat.qe.auto.testng.Assert.assertContainsMatch)
201012140001:43.576 - FINE: ssh root@jsefler-f12-candlepin.usersys.redhat.com cd /root/cp_product_utils; git pull (com.redhat.qe.tools.SSHCommandRunner.run)
201012140001:44.042 - FINE: Stdout: Already up-to-date.
 (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140001:44.044 - FINE: Stderr:  (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140001:44.044 - FINE: ExitCode: 0 (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140001:44.045 - INFO: Asserted: 0 is present in the list [0] (com.redhat.qe.auto.testng.Assert.pass)
201012140001:44.046 - FINE: ssh root@jsefler-f12-candlepin.usersys.redhat.com export FORCECERT=1; export GENDB=1; export HOSTNAME=jsefler-f12-candlepin.usersys.redhat.com; export IMPORTDIR=/root/cp_product_utils; cd /root/candlepin/proxy; buildconf/scripts/deploy (com.redhat.qe.tools.SSHCommandRunner.run)
201012140002:06.092 - FINE: Stdout: 
Stopping tomcat6: [  OK  ]
(in /root/candlepin/proxy, development)
Cleaning candlepin
Building candlepin
Downloading net.oauth.core:oauth:jar:20100527
Downloading http://oauth.googlecode.com/svn/code/maven/net/oauth/core/oauth/20100527/oauth-20100527.jar
Downloading net.oauth.core:oauth:pom:20100527
Downloading http://oauth.googlecode.com/svn/code/maven/net/oauth/core/oauth/20100527/oauth-20100527.pom
Downloading net.oauth.core:oauth-provider:jar:20100527
Downloading net.oauth.core:oauth-provider:pom:20100527
Compiling candlepin into /root/candlepin/proxy/target/classes
============ generating a new db ==============
   [schema] Executing Hibernate Tool with a JPA Configuration
   [schema] 1. task: hbm2ddl (Generates database schema)
(in /root/candlepin/proxy, development)
Completed in 3.915s
dropdb failed
 (com.redhat.qe.tools.SSHCommandRunner.runCommandAndWait)
201012140002:06.095 - FINE: Stderr: 
error: error reading /root/.m2/repository/net/oauth/core/oauth-provider/20100527/oauth-provider-20100527.jar; error in opening zip file
1 error
Buildr aborted!
RuntimeError : Failed to compile, see errors above

Comment 1 Bryan Kearney 2010-12-14 15:41:48 UTC
can you try removing the directory /root/.m2/repository/net/oauth and trying again? I deleted out my .m2 and it worked for me.

-- bk

Comment 2 John Sefler 2010-12-14 17:43:58 UTC
Thanks bkearney:  rm -rf /root/.m2/repository/net/oauth works for me too.


Note You need to log in before you can comment on or make changes to this bug.