Bug 663121 - Change the spec file to have "Provides: cim-server"
Summary: Change the spec file to have "Provides: cim-server"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tog-pegasus
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Vitezslav Crhonek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-14 18:57 UTC by Praveen K Paladugu
Modified: 2010-12-15 10:46 UTC (History)
2 users (show)

Fixed In Version: tog-pegasus-2.9.2-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-15 10:45:42 UTC
Type: ---


Attachments (Terms of Use)

Description Praveen K Paladugu 2010-12-14 18:57:50 UTC
Description of problem:
The "cim-server" alias is used by most of the sblim-providers to check if a CIMOM is installed. The sblim-sfcb CIMOM is updated with "Provides: cim-server". The intent here, the CMPI providers should install and register fine when either of tog-pegasus/sfcb CIMOM is installed. So, please add "Provides: cim-server" to the tog-pegasus package's spec file as well.

Version-Release number of selected component (if applicable):
2.9.2

How reproducible:
Everytime

Steps to Reproduce:
1. Install tog-pegasus package
2. Install sblim-cmpi-base package
3. 
  
Actual results:
Since tog-pegasus doesn't "Provides: cim-server", the sblim-cmpi-base package pulls in sblim-sfcb package unnecessarily.

Expected results:
sblim-cmpi-base package should install without pulling in sblim-sfcb package.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.