Bug 663202 - [RFE] STRICT mode should be brand configurable
[RFE] STRICT mode should be brand configurable
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
low Severity medium
: 3.0
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks: 820023
  Show dependency treegraph
 
Reported: 2010-12-14 18:28 EST by Jeff Fearn
Modified: 2012-10-30 23:10 EDT (History)
5 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:10:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2010-12-14 18:28:16 EST
Description of problem:
Currently the settings for strict mode are hard coded in Publican, banned tags and attributes should be configurable at the brand level.

Version-Release number of selected component (if applicable):
2.5
Comment 1 Jeff Fearn 2010-12-14 21:27:24 EST
Removed STRICT mode from code. Added configuration options banned_tags and banned_attrs. These can be set at the book or brand levels.

By default Publican does not, and will not, set these parameters. Brands wishing to impose restrictions will have to do so in the brand itself.

Fixed in revision 1690
Comment 2 Scott Mumford 2012-05-04 01:19:29 EDT
Jeff,

For testing purposes, could you provide some instructions on how to set these bans?

Since you stated they can be set at the book level, I tried adding a 'banned_tags:' entry to the publican.cfg file. Running 'publican print_banned' still shows no banned tags.

Cheers
Comment 3 Jared MORGAN 2012-05-08 19:20:16 EDT
Documentation required for this RFE. Publican User Guide 3.0 tracker ticket added to this issue.
Comment 4 Jeff Fearn 2012-05-17 02:47:16 EDT
banned_attrs and banned_tags can only be set in brands, so you'd need to update a brand to test this.

Just set either in a brands defaults.cfg or overrides.cfg ... you can be naughty and just `sudo gvim /usr/share/publican/Common_Content/RedHat/defaults.cfg` to test if you don't want to rebuild a brand.

e.g. banned_tags: "indexterm,para"


simpara should be enough para for anyone!
Comment 5 Michael Hideo 2012-06-07 22:08:32 EDT
(In reply to comment #4)
> banned_attrs and banned_tags can only be set in brands, so you'd need to
> update a brand to test this.
> 
> Just set either in a brands defaults.cfg or overrides.cfg ... you can be
> naughty and just `sudo gvim
> /usr/share/publican/Common_Content/RedHat/defaults.cfg` to test if you don't
> want to rebuild a brand.
> 
> e.g. banned_tags: "indexterm,para"
> 
> 
> simpara should be enough para for anyone!

execute the above.
Comment 6 Ruediger Landmann 2012-06-15 22:27:48 EDT
Verified in publican-3.0-0.fc17.t180.noarch

Setting

banned_tags: "indexterm,para"

in brand default.cfg and building a book gives:

ERROR: Banned tag (para) detected. Discuss this with your brands owners if you think this is in error.

Setting:

banned_attrs: "id"

in brand default.cfg and building a book gives:

ERROR: Banned attribute (id) detected. Discuss this with your brands owners if you think this is in error.

Note You need to log in before you can comment on or make changes to this bug.