Bug 663203 - [RFE] mock SRPM validation
[RFE] mock SRPM validation
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-14 18:33 EST by Jeff Fearn
Modified: 2011-08-15 21:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-25 20:42:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2010-12-14 18:33:30 EST
Description of problem:
Currently there is no validation of sources supplied in mock builds. Publican should detect mock and use rpmlint to validate the source RPM.

Version-Release number of selected component (if applicable):
2.5

Actual results:
Invalid SRPMs are use and generate invalid RPMs

Expected results:
Invalid SRPMS are detected and rejected.
Comment 1 Jeff Fearn 2010-12-14 21:24:24 EST
Added call to rpmlint when mock is detected. Build will croak if rpmlint has errors.

Fixed in revision 1690
Comment 2 Jeff Fearn 2011-07-05 05:26:56 EDT
Back ported to branches/publican-2x

Committed revision 1800.
Comment 3 Ruediger Landmann 2011-07-25 00:04:30 EDT
Verified on Publican 2.6-0.t2
Comment 4 Andrew Beekhof 2011-08-15 07:53:37 EDT
What on earth for?

We use publican to build our in-tree docs, but its now barfing in fedora-15 because we have an unavoidable and completely unrelated rpmlint error.

This is in addition to being forced into having a versioned build dependancy on publican.
Comment 5 Andrew Beekhof 2011-08-15 21:43:28 EDT
Adding some clarifications after an IRC chat with Ryan:

The upstream project is Pacemaker and the command we're running from the Makefile is:
  $(PUBLICAN) build --publish --langs=all --formats=$(DOCBOOK_FORMATS)

The SRPM publican is checking in this case is the pacemaker one, since the docs are in the same SRPM as the code.  So when rpmlint complains about something in the code, it causes publican abort.

Ryan explained to me why the checks were necessary, but perhaps they could be limited to the "package" command.

Note You need to log in before you can comment on or make changes to this bug.