Bug 663206 - [RFE] publican creates invalid spec files
[RFE] publican creates invalid spec files
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-14 18:36 EST by Jeff Fearn
Modified: 2011-07-25 20:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-25 20:42:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2010-12-14 18:36:28 EST
Description of problem:
It is invalid for summary and description to be epty or only contain white space. Currently Publican will happily generate invalid spec files if these fields contain white space.

Version-Release number of selected component (if applicable):
2.5

Actual results:
Packages that fail rpmlint are created when subtitle or abstract only contain white space.

Expected results:
Publican should refuse to create invalid packages.
Comment 1 Jeff Fearn 2010-12-14 21:28:53 EST
Added code to check subtitle and abstract are valid before creating spec file. tar.gz file will still be created regardless of RPM issues.

Fixed in revision 1690
Comment 2 Jeff Fearn 2011-07-05 05:27:38 EDT
Back ported to branches/publican-2x

Committed revision 1800.
Comment 3 Rebecca Newton 2011-07-12 20:40:57 EDT
Hi Jeff, I'm trying to build a set and I am getting:

WARNING: You can not create RPM packages with a blank subtitle. Skipping RPM creation.
pushd tmp
Use of uninitialized value in subroutine entry at /usr/bin/publican line 910.
Can't locate srpm, CVS import aborted at /usr/bin/publican line 912

This is expected, due to this update, but both the Set_Info.xml and the Book_Info.xmls for the included books HAVE subtitles, so this error probably shouldn't show up, should it?
Comment 4 Rebecca Newton 2011-07-12 20:58:36 EDT
It does work fine for books, though.
Comment 7 Rebecca Newton 2011-07-13 00:54:32 EDT
Fix verified. I can't reproduce the earlier bug. I must have been looking at it wrong.

Note You need to log in before you can comment on or make changes to this bug.