Bug 66333 - can't handle large files
can't handle large files
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: lsof (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-07 19:32 EDT by Jon Willeke
Modified: 2007-04-18 12:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-07 19:42:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
create a 4 GB file (1.54 KB, text/plain)
2002-06-07 19:34 EDT, Jon Willeke
no flags Details

  None (edit)
Description Jon Willeke 2002-06-07 19:32:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (WinNT; U)

Description of problem:
I created a 16 GB database file.  The lsof command doesn't seem to like it:

  $ /usr/sbin/lsof data.dat
  lsof: status error on data.dat: Value too large for defined data type
  lsof 4.51 (latest revision at ftp://vic.cc.purdue.edu/pub/tools/unix/lsof)
   usage: [-?abhlnNoOPRstUvV] [-c c] [+|-d s] [+D D] [+|-f]
   [-F [f]] [-g [s]] [-i [i]] [+|-L [l]] [+|-M] [-o [o]] [-p s]
   [+|-r [t]] [-S [t]] [-T [t]] [-u s] [+|-w] [--] [names]
  Use the ``-h'' option to get more help information.

A Deja search determined that this was likely due to the command not supporting large files.

Version-Release number of selected component (if applicable): 4.51-2


How reproducible:
Always

Steps to Reproduce:
1. Create a large file (attached lseek.c creates data.dat, a sparse 4 GB file)
2. /usr/sbin/lsof data.dat

Actual Results:  Command displayed "Value too large for defined data type" warning.

Expected Results:  Unless the file is in use, the command should have no output.

Additional info:

I found the following in the lsof FAQ list: "Large file support is defined dialect by dialect in the lsof source files and Configure script."  Version 4.51, included with RH 
7.3, does not define large file support for the linux dialect.  More recent versions, including the current 4.63, do.
Comment 1 Jon Willeke 2002-06-07 19:34:58 EDT
Created attachment 60144 [details]
create a 4 GB file
Comment 2 Jon Willeke 2002-06-07 19:41:59 EDT
You can also use dd to create a file that demonstrates this problem:

  $ dd if=/dev/null of=foo.dat bs=1 count=1 seek=4000000000
  0+0 records in
  0+0 records out
  $ /usr/sbin/lsof foo.dat
  lsof: status error on foo.dat: Value too large for defined data type
  ...
Comment 3 Jakub Jelinek 2002-06-21 11:37:16 EDT
Should be fixed in lsof-4.63-1 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.