Bug 66339 - X hangs when starting KDE with glibc 2.2.90-10
X hangs when starting KDE with glibc 2.2.90-10
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-07 23:27 EDT by Robin Green
Modified: 2016-11-24 09:57 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 23:24:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2002-06-07 23:27:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
I tried upgrading to glibc 2.2.90-10, and when I rebooted, starting a KDE
session by typing "startx" caused the X server to hang after displaying the
expected blue background (no "starting KDE" splash screen appeared). The mouse
pointer was frozen. CTRL+ALT+BACKSPACE to quit the X server, and CTRL+ALT+F1 to
switch to a VT, both had no effect.

Version-Release number of selected component (if applicable):
XFree86-4.2.0-8

How reproducible:
Always

Steps to Reproduce:
1. Install glibc 2.2.90-10
2. Make KDE the default
3. Run startx

Actual Results:  X hangs

Expected Results:  KDE should start up normally

Additional info:

Configuration:

XFree86-4.2.0-8
kdebase-3.0.1-1
Linux 2.4.18 with preempt patch

Downgrading back to glibc from RH7.3 fixed the problem.
Comment 1 Mike A. Harris 2002-06-09 23:35:53 EDT
We do not support using rawhide glibc with RHL 7.3.  Also, we do not support
user compiled kernels with or without patches.

Also, if you're testing rawhide, things are very likely to be broken at
any given point in time, especially if mixing rawhide and 7.3.  Can you
reproduce this problem using a fully installed rawhide system with an
official Red Hat kernel (or the rawhide kernel)?
Comment 2 Arjan van de Ven 2002-06-10 03:17:04 EDT
Ugh preempt... you really do like living on the edge...
Anyway if anything it looks like a glibc bug
Comment 3 Bill Nottingham 2002-06-21 23:24:38 EDT
2.2.90-12 may fix some of this for you; a problem with threads was fixed there.
Comment 4 Robin Green 2002-08-24 13:10:59 EDT
can't reproduce now

Note You need to log in before you can comment on or make changes to this bug.