Bug 663402 - [abrt] evolution-data-server-2.32.1-1.fc14: g_mutex_free_posix_impl: Process /usr/libexec/e-addressbook-factory was killed by signal 6 (SIGABRT)
Summary: [abrt] evolution-data-server-2.32.1-1.fc14: g_mutex_free_posix_impl: Process ...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ff107f00ba8d4a156dc2b03e208...
: 657413 663905 663939 681508 681724 688230 695399 701077 724958 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-15 17:14 UTC by Giovanni Campagna
Modified: 2011-07-26 11:13 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-17 08:54:35 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (19.67 KB, text/plain)
2010-12-15 17:14 UTC, Giovanni Campagna
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 637439 0 None None None Never

Description Giovanni Campagna 2010-12-15 17:14:45 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/e-addressbook-factory
component: evolution-data-server
crash_function: g_mutex_free_posix_impl
executable: /usr/libexec/e-addressbook-factory
kernel: 2.6.35.9-64.fc14.x86_64
package: evolution-data-server-2.32.1-1.fc14
rating: 4
reason: Process /usr/libexec/e-addressbook-factory was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1292433245
uid: 500

How to reproduce
-----
Just opened Evolution Calendar View

Comment 2 Milan Crha 2010-12-16 08:12:19 UTC
Thanks for a bug report. What is your libsoup version, please? Could you update it to 2.32.2 and try again, if you do not have it yet, please? Thanks in advance.

Comment 3 Giovanni Campagna 2010-12-16 20:05:23 UTC
yum info says:
Name        : libsoup
Arch        : x86_64
Version     : 2.32.2
Release     : 1.fc14
which is the latest version in testing

Comment 4 Milan Crha 2010-12-17 08:54:35 UTC
Ah, OK, thanks, I see I overlooked that there are actually two threads working on the same libsoup session, so this is evolution-data-server's issue, namely of the Google backend not clearing itself properly.

I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=637439

Thread 2 (Thread 3865):
#0  0x0000003d14e30351 in soup_message_io_cleanup (msg=0x7f680c04c0f0 [SoupMessage]) at soup-message-io.c:94
#1  0x0000003d14e2c305 in finalize (object=0x7f680c04c0f0 [SoupMessage]) at soup-message.c:157
#2  0x000000375900f2f4 in g_object_unref (_object=0x7f680c04c0f0) at gobject.c:2695
#3  0x0000003d16a1a2b2 in authenticate (self=0x7f68080048f0 [GDataContactsService], username=<value optimized out>, password=<value optimized out>, captcha_token=<value optimized out>, captcha_answer=<value optimized out>, cancellable=0x0, error=0x7f6813ffecc8) at gdata/gdata-service.c:774
#4  0x0000003d16a1adf5 in gdata_service_authenticate (self=<value optimized out>, username=<value optimized out>, password=<value optimized out>, cancellable=<value optimized out>, error=<value optimized out>) at gdata/gdata-service.c:812

Thread 1 (Thread 3864):
#0  0x0000003756434085 in raise () from /lib64/libc-2.12.90.so
#1  0x0000003756435a36 in abort () from /lib64/libc-2.12.90.so
#2  0x000000375804ab8a in g_logv (log_domain=0x3758c029e8 "GThread", log_level=<value optimized out>, format=0x3758c02d48 "file %s: line %d (%s): error '%s' during '%s'", args1=0x7f6818bb8b10) at gmessages.c:557
#3  0x000000375804ac13 in g_log (log_domain=<value optimized out>, log_level=<value optimized out>, format=<value optimized out>) at gmessages.c:577
#4  0x0000003758c024e6 in g_mutex_free_posix_impl (mutex=0x7f680c0041c0) at gthread-posix.c:171
#5  0x0000003d14e3b2bc in finalize (object=0x7f6808009600 [SoupSessionSync]) at soup-session-sync.c:80
#6  0x000000375900f2f4 in g_object_unref (_object=0x7f6808009600) at gobject.c:2695
#7  0x0000003d16a1abd1 in gdata_service_dispose (object=0x7f68080048f0 [GDataContactsService]) at gdata/gdata-service.c:218

Comment 5 Milan Crha 2010-12-20 08:20:49 UTC
*** Bug 657413 has been marked as a duplicate of this bug. ***

Comment 6 Milan Crha 2010-12-20 08:21:08 UTC
*** Bug 663905 has been marked as a duplicate of this bug. ***

Comment 7 Milan Crha 2010-12-20 08:25:49 UTC
*** Bug 663939 has been marked as a duplicate of this bug. ***

Comment 8 Milan Crha 2011-03-03 07:14:42 UTC
*** Bug 681508 has been marked as a duplicate of this bug. ***

Comment 9 Milan Crha 2011-03-03 07:20:40 UTC
*** Bug 681724 has been marked as a duplicate of this bug. ***

Comment 10 Milan Crha 2011-03-17 09:39:55 UTC
*** Bug 688230 has been marked as a duplicate of this bug. ***

Comment 11 Milan Crha 2011-04-12 05:05:18 UTC
*** Bug 695399 has been marked as a duplicate of this bug. ***

Comment 12 Milan Crha 2011-05-02 05:56:17 UTC
*** Bug 701077 has been marked as a duplicate of this bug. ***

Comment 13 Milan Crha 2011-07-26 11:13:29 UTC
*** Bug 724958 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.