Bug 663419 - Error of Metatdata file does not match checksum" when using pup
Error of Metatdata file does not match checksum" when using pup
Status: CLOSED DUPLICATE of bug 638922
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.8
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: James Antill
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-15 13:25 EST by Charles Knox
Modified: 2013-01-10 05:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-15 14:12:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Knox 2010-12-15 13:25:26 EST
Description of problem:Trying to run pup to install new patches.  pup opens an error box saying "An unhandled exception has occured.  This is most likely a bug.  Please save the crash dump report and file a detailed bug report against pirut at https://bugzilla.redhat.com/bugzilla


Version-Release number of selected component (if applicable):


How reproducible:Every time I run pup on x86_64 machines running RHEL5 Workstation (Desktop plus workstation additional channel) today.


Steps to Reproduce:
1.
2.
3.
  
Actual results:Component: pirut
Summary: TB7d428655 rhnplugin.py:319:_getFile:RepoError: failed to retrieve repodata/c55860d7e201ad141a1b173a01723c8ec168b6c3-updateinfo.xml.gz from rhel-x86_64-client-5
error was [Errno -1] Metadata file does not match checksum

Traceback (most recent call last):
  File "/usr/sbin/pup", line 617, in ?
    main()
  File "/usr/sbin/pup", line 613, in main
    pup.run()
  File "/usr/sbin/pup", line 451, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 291, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 347, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 367, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1494, in retrieveMD
    return self._retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1534, in _retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 319, in _getFile
    raise yum.Errors.RepoError, \
RepoError: failed to retrieve repodata/c55860d7e201ad141a1b173a01723c8ec168b6c3-updateinfo.xml.gz from rhel-x86_64-client-5
error was [Errno -1] Metadata file does not match checksum

Local variables in innermost frame:
e: [Errno -1] Metadata file does not match checksum
url: None
text: rhel-x86_64-client-5/updateinfo
self: rhel-x86_64-client-5
cache: False
reget: None
relative: repodata/c55860d7e201ad141a1b173a01723c8ec168b6c3-updateinfo.xml.gz
start: None
checkfunc: (<bound method RhnRepo.checkMD of <rhnplugin.RhnRepo object at 0x1b5e8f90>>, ('updateinfo',), {})
copy_local: 1
end: None
local: /var/cache/yum/rhel-x86_64-client-5/c55860d7e201ad141a1b173a01723c8ec168b6c3-updateinfo.xml.gz



Expected results:update success


Additional info:pup on RHEL5 workstation on i386 seems to work.  I did at least two i386 machines while the x86_64 machines fail with pup.
Comment 1 James Antill 2010-12-15 14:12:37 EST

*** This bug has been marked as a duplicate of bug 638922 ***

Note You need to log in before you can comment on or make changes to this bug.