Bug 663446 - [abrt] evolution-2.32.1-1.fc14: gtk_file_system_model_sort: Process /usr/bin/evolution was killed by signal 6 (SIGABRT)
Summary: [abrt] evolution-2.32.1-1.fc14: gtk_file_system_model_sort: Process /usr/bin/...
Keywords:
Status: CLOSED DUPLICATE of bug 603781
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b281687a81c81dd30f070edae71...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-15 20:17 UTC by Jaime RCZ
Modified: 2011-01-03 08:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-03 08:21:56 UTC


Attachments (Terms of Use)
File: backtrace (58.72 KB, text/plain)
2010-12-15 20:17 UTC, Jaime RCZ
no flags Details

Description Jaime RCZ 2010-12-15 20:17:43 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: evolution
comment: Try to close evolution, and I need to kill the process. Happens everytime I try to close Evolution.
component: evolution
crash_function: gtk_file_system_model_sort
executable: /usr/bin/evolution
kernel: 2.6.35.9-64.fc14.x86_64
package: evolution-2.32.1-1.fc14
rating: 4
reason: Process /usr/bin/evolution was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1292362926
uid: 500

How to reproduce
-----
1. Try to Close Evolution, and window freezes.
2. I need to kill process from console
3.

Comment 1 Jaime RCZ 2010-12-15 20:17:45 UTC
Created attachment 468960 [details]
File: backtrace

Comment 2 Milan Crha 2010-12-16 08:25:14 UTC
Thanks for a bug report. Below is a main thread of your application, which seems to be stuck during attachment loading. I sit possible your last message had too large attachment, which was only reading, or you were composing a message with a large attachment? There is definitely something attachment related in the crash, so I'm asking on these things. It would be good to find exact steps for a reproducer, to move this upstream with them. Thanks in advance.

#2  0x0000003ea6867584 in g_assertion_message (domain=<value optimized out>, file=<value optimized out>, line=<value optimized out>, func=0x31d4129530 "gtk_file_system_model_sort", message=0x3217a20 "assertion failed: (r == n_visible_rows)") at gtestutils.c:1358
#3  0x0000003ea6867b20 in g_assertion_message_expr (domain=0x31d41119db "Gtk", file=0x31d4129272 "gtkfilesystemmodel.c", line=746, func=0x31d4129530 "gtk_file_system_model_sort", expr=<value optimized out>) at gtestutils.c:1369
#4  0x00000031d3eff7ea in gtk_file_system_model_sort (model=0x3b1e3c0 [GtkFileSystemModel]) at gtkfilesystemmodel.c:746
#5  0x00000031d3f01a58 in _gtk_file_system_model_update_file (model=0x3b1e3c0 [GtkFileSystemModel], file=0x31031a0, info=0x7f87980c66f0, requires_resort=1) at gtkfilesystemmodel.c:1782
#6  0x00000031d325f258 in complete_in_idle_cb_for_thread (_data=0x3302d30) at gsimpleasyncresult.c:757
#7  0x0000003ea6841e33 in g_main_dispatch
#8  g_main_context_dispatch (context=0x1aef750) at gmain.c:2702
#9  0x0000003ea6842610 in g_main_context_iterate
#10 0x0000003ea6842c82 in g_main_loop_run (loop=0x4037a70) at gmain.c:2988
#11 0x00000031d3ec38a4 in IA__gtk_dialog_run (dialog=0x2f81dd0 [GtkFileChooserDialog]) at gtkdialog.c:1094
#12 0x00000037fcc3a7ee in e_attachment_store_run_file_chooser_dialog (store=0x3ea33c0 [EAttachmentStore], dialog=0x2f81dd0 [GtkFileChooserDialog]) at e-attachment-store.c:478
#13 0x00000037fcc3a9f0 in e_attachment_store_run_load_dialog (store=0x3ea33c0 [EAttachmentStore], parent=0x297f910 [EMsgComposer]) at e-attachment-store.c:529
#14 0x0000003ea740e03e in g_closure_invoke
#15 0x0000003ea741ee87 in signal_emit_unlocked_R
#16 0x0000003ea74287b5 in g_signal_emit_valist
#17 0x0000003ea7428983 in g_signal_emit
#18 0x00000031d3e747d3 in _gtk_action_emit_activate
#19 0x0000003ea740e03e in g_closure_invoke
#20 0x0000003ea741f062 in signal_emit_unlocked_R
#21 0x0000003ea74287b5 in g_signal_emit_valist
#22 0x0000003ea7428983 in g_signal_emit
#23 0x00000031d3e90a85 in gtk_real_button_released
#24 0x0000003ea740e03e in g_closure_invoke
#25 0x0000003ea741e64c in signal_emit_unlocked_R
#26 0x0000003ea74287b5 in g_signal_emit_valist
#27 0x0000003ea7428983 in g_signal_emit
#28 0x00000031d3e8f527 in gtk_button_button_release
#29 0x00000031d3f4e223 in _gtk_marshal_BOOLEAN__BOXED
#30 0x0000003ea740e03e in g_closure_invoke
#31 0x0000003ea741ec98 in signal_emit_unlocked_R
#32 0x0000003ea7428555 in g_signal_emit_valist
#33 0x0000003ea7428983 in g_signal_emit
#34 0x00000031d4085aef in gtk_widget_event_internal (...) at gtkwidget.c:4992
#35 0x00000031d3f4bd33 in IA__gtk_propagate_event (...) at gtkmain.c:2460
#36 0x00000031d3f4c103 in IA__gtk_main_do_event (...) at gtkmain.c:1665
#37 0x00000031d3a61a8c in gdk_event_dispatch (...) at gdkevents-x11.c:2377
#38 0x0000003ea6841e33 in g_main_dispatch (context=0x1aef750) at gmain.c:2149
#39 g_main_context_dispatch (context=0x1aef750) at gmain.c:2702
#40 0x0000003ea6842610 in g_main_context_iterate (...) at gmain.c:2780
#41 0x0000003ea6842c82 in g_main_loop_run (loop=0x2075250) at gmain.c:2988
#42 0x00000031d3f4b0b7 in IA__gtk_main () at gtkmain.c:1237
#43 0x0000000000402679 in main (argc=1, argv=0x7fffd05bb848) at main.c:679

Comment 3 David Tardon 2011-01-03 08:21:56 UTC

*** This bug has been marked as a duplicate of bug 603781 ***


Note You need to log in before you can comment on or make changes to this bug.