Bug 66359 - Non-working Czech support on console
Non-working Czech support on console
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-08 10:07 EDT by Milan Kerslager
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-06 07:15:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2002-06-08 10:07:51 EDT
Script /etc/init.d/keytable need /usr/bin/loadkeys but there is /bin/loadkeys.

Console does not accept non-iso8859-1 characters after normal installation (my 
is Czech language). It seems that kbd package is broken.
Comment 1 Milan Kerslager 2002-06-08 10:19:38 EDT
Console TUI tools are broken too (setup, ntsysv etc).

My /etc/sysconfig/i18n:

LANG="cs_CZ.utf8"
SYSFONT="LatArCyrHeb-16"
SYSFONTACM="utf8"

Surely - Czech language does not have Cyrilic nor Hebrew nor Arabian chars. I 
tryed lat2-16 instead of LatArCyrHeb-16 but this do not work too.
Comment 2 Aleksey Nogin 2002-06-17 20:41:18 EDT
Yes, kdb package still appears to be badly broken in beta2. 

(A) /etc/init.d/keytable looks for /usr/bin/loadkeys and quits if it is not found.
1) It should look for /bin/loadkeys or /usr/bin/loadkeys should be brough back
2) Even if loadkeys is truely missing, /etc/init.d/keytable should *still* be
going - it should still do /sbin/setsysfont.

(B) (Not sure whose fauts it is - kbd, anaconda, me?):
3) after 7.3 -> Milan beta 2 upgrade /etc/sysconfig/i18n had:
SYSFONT="cyr-16"
However there is no such font in kbd! (there is cyr-sun16, but no cyr-16).
4) No matter how I set the mapping variables (SYSFONTACM, UNIMAP) I could not
get /sbin/setsysfont to display the KOI8-R correctly while using the "cyr-sun16"
font. I ended up having to switch to using a koi8r-8x16 (which is much uglier
than cyr-sun16).

P.S. (2)-(4) are probably separate bugs - I will file them as such if they are
still there after (1) is fixed.
Comment 3 Bernhard Rosenkraenzer 2002-08-05 09:07:21 EDT
loadkeys location fixed; leaving open for the other issues.
Comment 4 Eido Inoue 2003-01-05 21:36:12 EST
Is this still a problem with the latest release?
Comment 5 Milan Kerslager 2003-01-06 07:15:36 EST
Beta3 (Phoebe) seems to be OK.

Note You need to log in before you can comment on or make changes to this bug.