Bug 66361 - Binary configuration files are bad
Binary configuration files are bad
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: alchemist (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-08 12:05 EDT by Simon Perreault
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-08 12:05:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Perreault 2002-06-08 12:05:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020605

Description of problem:
Alchemist stores the configuration for multiple configuration tools in XML,
which is good. However, this XML is compiled in some way and then stored in
/etc/alchemist. Unless there is a very good reason not to do so, configuration
should be stored in play text, so that
1) It can be altered by hand, without using the configuration tools
2) It can be parsed and edited by scripts which have XML support but which don't
have (yet) alchemist support (think Perl).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to write a web configuration interface for printers in perl
2. Try to parse some files under /etc/alchemist, because printconf will
overwrite changes with its own configuration.
	

Actual Results:  This is binary and can't be parsed.

Expected Results:  This should have been textual XML readable by a human.

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-06-10 10:50:46 EDT
It's just gzipped...

Note You need to log in before you can comment on or make changes to this bug.