Bug 663610 - JON 241: NullPointerException in JON-2.4.1 installation
JON 241: NullPointerException in JON-2.4.1 installation
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Installer (Show other bugs)
3.0.0
Unspecified Unspecified
low Severity medium (vote)
: ---
: ---
Assigned To: Lukas Krejci
Corey Welton
: Reopened
Depends On: 665070
Blocks: jon241-bugs
  Show dependency treegraph
 
Reported: 2010-12-16 06:34 EST by Rajan Timaniya
Modified: 2013-08-31 09:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 09:10:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server log (386.83 KB, application/octet-stream)
2010-12-16 06:34 EST, Rajan Timaniya
no flags Details

  None (edit)
Description Rajan Timaniya 2010-12-16 06:34:24 EST
Created attachment 469122 [details]
server log

Description of problem:
JON-2.4.1 installation gives NullPointerException in server log.

2010-12-16 16:29:38,939 ERROR [org.apache.catalina.connector.CoyoteAdapter] An exception or error occurred in the container during the request processing
java.lang.NullPointerException
	at org.apache.catalina.connector.CoyoteAdapter.parseSessionCookiesId(CoyoteAdapter.java:507)
	at org.apache.catalina.connector.CoyoteAdapter.postParseRequest(CoyoteAdapter.java:449)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:239)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
	at java.lang.Thread.run(Thread.java:619)
2010-12-16 16:29:38,948 ERROR [org.apache.catalina.connector.CoyoteAdapter] An exception or error occurred in the container during the request processing
java.lang.NullPointerException
	at org.apache.catalina.connector.CoyoteAdapter.parseSessionCookiesId(CoyoteAdapter.java:507)
	at org.apache.catalina.connector.CoyoteAdapter.postParseRequest(CoyoteAdapter.java:449)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:239)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
	at java.lang.Thread.run(Thread.java:619)
2010-12-16 16:29:39,253 WARN  [org.jboss.seam.Component] Component class should be serializable: AddNewOpenMapMemberPropertyToResourceConfigurationUIBean

Version-Release number of selected component (if applicable):
JON-2.4.1 build #42 (build number: 10963:0a53ca3)

How reproducible:
Always

Steps to Reproduce:
1) Start JON server, fill database information on installation screen and click on 'Install' button
2) Observe server log

Note: NPE is not blocking JON installation.
  
Actual results:
JON-2.4.1 installation gives NullPointerException in server log.

Expected results:
JON-2.4.1 should not give NullPointerException during installation.

Additional info:
Please refer attached file for server log.
Comment 1 Lukas Krejci 2010-12-16 16:27:07 EST
Making this private because this is specific to JON.

This got introduced by inclusion of JBossWeb 2.0.0_CP14 (bug 659580).

It is a known issue of CP14, see https://issues.jboss.org/browse/JBWEB-188.
Comment 2 Heiko W. Rupp 2010-12-21 07:48:46 EST
I agree, it is completely harmless.  Install goes fine and UI runs nicely. Also it only shows at initial install and not at subsequent starts.
Comment 3 Lukas Krejci 2010-12-21 08:02:15 EST
Making this public again so that customers can be aware of this if the fix isn't ready for the release.

As Heiko said, this is mostly a non-issue because it happens only during the installation process, possibly because of the way we deploy the app and undeploy the installer in the root context of the application server.
Comment 4 Lukas Krejci 2010-12-21 10:06:30 EST
This bug should cause no functional regression. 

QA, could you please re-test this and confirm that everything works as expected, even though the NPEs are still present in the log?
Comment 5 Rajan Timaniya 2010-12-22 04:20:27 EST
Verified on JON-2.4.1

There are some NPEs in server log but I haven't find any other functional error.
Test automation result also looks good.
Comment 6 Rajan Timaniya 2010-12-22 09:57:40 EST
Can we add this bug under the known bug list of JON-2.4.1 or have note for this in release note?
Comment 9 Lukas Krejci 2011-01-03 07:38:49 EST
This is now being handled as a documentation bug.
Comment 10 Larry O'Leary 2012-11-27 19:22:38 EST
Component bugs should not be handled via documentation unless we plan on addressing this. Basically, what has happened here is that this bug has been closed as WONTFIX due to the impact being so minimal it was not worth the effort to upgrade the component. Additionally, this may no longer be relevant in master with the container upgrade to AS7.
Comment 11 Deon Ballard 2012-12-20 19:30:03 EST
I'm reopening this, since GSS wants this to be considered for a fix by engineering.
Comment 12 Heiko W. Rupp 2013-08-31 09:10:34 EDT
This BZ applies to the old container. This specific bug is no longer valid in RHQ 4.6+

Note You need to log in before you can comment on or make changes to this bug.