Bug 663725 - subscription-manager firstboot crashes upon startup
Summary: subscription-manager firstboot crashes upon startup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: J.C. Molet
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-12-16 16:57 UTC by J.C. Molet
Modified: 2013-01-10 10:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:38:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description J.C. Molet 2010-12-16 16:57:11 UTC
Description of problem:
When you launch first boot, it crashes due to errors with subscription-manager.

Version-Release number of selected component (if applicable):
subscription-manager-0.93.3-1.git.37.da5f267.fc14.x86_64
subscription-manager-gnome-0.93.3-1.git.37.da5f267.fc14.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install latest build of subscription manager
2. run firstboot

  
Actual results:
First boot crashes upon launch:

firstboot 1.110.8 exception report
Traceback (most recent call last):
  File "/usr/sbin/firstboot", line 192, in <module>
    config.moduleList = loadModules(config.moduleDir, config.mode)
  File "/usr/lib/python2.6/site-packages/firstboot/loader.py", line 101, in loadModules
    obj = loaded.moduleClass()
  File "/usr/share/firstboot/modules/rhsm_entitlement_choose.py", line 28, in __init__
    self.vbox = managergui.rhsm_xml.get_widget("entitlementChooseVbox")
AttributeError: 'module' object has no attribute 'rhsm_xml'

Local variables in innermost frame:
self: <rhsm_entitlement_choose.moduleClass instance at 0x1d906c8>

Expected results:
First boot runs.

Comment 2 J.C. Molet 2010-12-23 18:22:55 UTC
firstboot now launches

subscription-manager-0.93.7-1.git.3.fbdf967.el6.x86_64
subscription-manager-gnome-0.93.7-1.git.3.fbdf967.el6.x86_64

Comment 3 errata-xmlrpc 2011-05-19 13:38:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.