Bug 663756 - subscripton-manger-gui: exiting the calendar - usability suggestion
Summary: subscripton-manger-gui: exiting the calendar - usability suggestion
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Chris Duryee
QA Contact: J.C. Molet
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-12-16 18:55 UTC by J.C. Molet
Modified: 2011-05-19 13:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:38:17 UTC
Target Upstream Version:


Attachments (Terms of Use)
calendar exit (129.80 KB, image/png)
2011-01-24 19:02 UTC, J.C. Molet
no flags Details
calendar fix (154.22 KB, image/png)
2011-01-24 19:34 UTC, J.C. Molet
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0611 normal SHIPPED_LIVE new package: subscription-manager 2011-05-18 17:56:21 UTC

Description J.C. Molet 2010-12-16 18:55:44 UTC
Description of problem:
When you open the calendar dropdown/popup to select a different date in either the 'become compliant' or the 'all available subscriptions' screens, there you cannot exit the date chooser by clicking outside of it.

Version-Release number of selected component (if applicable):
subscription-manager-0.93.3-1.git.37.da5f267.fc14.x86_64
subscription-manager-gnome-0.93.3-1.git.37.da5f267.fc14.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open subscription-manager-gui
2. register your client
3. click on 'become compliant'
4. click the drop down to select a different date
5. try to cancel this selection by clicking outside of the calendar box 
  
Actual results:
Nothing.  You cannot exit this selection box without actually selecting a date.

Expected results:
Clicking or double clicking outside of the selection box would 'cancel' the interaction and set it back to whatever date it was at before the dialog was opened.

Additional info:
usability suggestion - current method could be confusing to some users

Comment 1 Chris Duryee 2011-01-14 15:34:11 UTC
It looks like the date box went away in the latest builds. Marking as closed/notabug.

Comment 2 Chris Duryee 2011-01-14 15:39:14 UTC
re-opening, my mistake. I was looking at the wrong hash.

Comment 4 J.C. Molet 2011-01-24 19:02:17 UTC
Created attachment 475021 [details]
calendar exit

Comment 5 J.C. Molet 2011-01-24 19:03:19 UTC
Fix was created in the form of a "Today" button.  This resets the date to the current one and exists the calendar choose dialog.  

Tested in version:
subscription-manager-gnome-0.93.14-1.el6.x86_64

Comment 6 J.C. Molet 2011-01-24 19:34:22 UTC
Created attachment 475032 [details]
calendar fix

(In reply to comment #5)
> Fix was created in the form of a "Today" button.  This resets the date to the
> current one and exists the calendar choose dialog.  
> 
> Tested in version:
> subscription-manager-gnome-0.93.14-1.el6.x86_64

Correction, The real fix is the addition of the X button as tested in version:
subscription-manager-gnome-0.93.14-1.git.6.0632b6a.el6.x86_64

Comment 7 errata-xmlrpc 2011-05-19 13:38:17 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html


Note You need to log in before you can comment on or make changes to this bug.