Bug 663772 - Dashboard: Cannot load after adding resources to inventory, leaving and returning
Dashboard: Cannot load after adding resources to inventory, leaving and retur...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Simeon Pinder
Corey Welton
:
Depends On:
Blocks: rhq4 jon30-dashboard
  Show dependency treegraph
 
Reported: 2010-12-16 14:34 EST by Corey Welton
Modified: 2011-05-23 21:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2010-12-16 14:34:34 EST
Description of problem:

Upon initial install, user can see dashboard. but after inventorying a resource, going somewhere else (i.e., Inventory) and trying to return to dashboard, it hangs indefinitely.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1.  Install RHQ fresh.  
2.  Add a platform to inventory
3.  Navigate somewhere else in UI, i.e., Inventory tab.
4.  Try to navigate back to Dashboard
  
Actual results:
Dashboard never seems to load. User gets a page with basic header stuff and search bar, but no dash.

Expected results:
Working Dashboard

Additional info:
This is not a local connection, i.e., in the office -- I am connecting over the VPN to my test VM.  However, it doesn't seem to be a bandwidth issue -- the bandwidth use on my router is negligible.  Latency perhaps?
Comment 1 Simeon Pinder 2010-12-17 11:23:45 EST
I am not able to reproduce this with top of tree in master(12/17/10 approx. 10:30a.m est) with commit hash 2bbb4cf551c52288216a1d6ad3e1a43d44c320e3.  I tried this several times with fresh db each time.

A few questions: 
 - How did you import the platform? Discovery Queue portlet or Inventory > Discovery Queue? I tried both with fresh databases with same results.
 - Is there a specific build that I can use to try to reproduce this?
 - Can you retry this with the latest build?

The last thing I'd ask in this case is whether you were on a really slow box or if it's possible that the UI just froze on you that one time.  In cases like these an F5 refresh may serve to restart the browser. 

I've only seen indefinite hangs in the dashboard/ui when I'm running the dev debug console and I've made some change that cause coreGui to no longer compile.
Comment 2 Jay Shaughnessy 2011-02-11 18:28:10 EST
fixed.
Comment 3 Corey Welton 2011-02-14 14:15:05 EST
Marking this verified. Not seeing it happen anymore.
Comment 4 Corey Welton 2011-05-23 21:13:28 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:13:29 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:13:29 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.